Opening PDFs & Office documents from SharePoint 2010 search doesn't allow domain users access

When domain users search SharePoint 2010, they are unable to open the document from the search results.  They are prompted for the Window Login credentials, but their credentials do not allow them to open the file from the search.  They are able to browse to the file and open it without any prompts or problems.  They are also able to save a file to their computer from the search and then open it that way.  

When they have their search results and the prompt for the Windows Login, if I login with my administrative credentials, I am prompted to Check Out & Open, Open, or Cancel.  Opening works for me.

It appears, to me, that this would point to a permissions issue.  How do I go about granting the domain users the same permissions in search, as they would if they browsed directly to the document?  The users state that they did not have this issue when they were on Windows XP.  Only since they have been upgraded to Windows 7, has this started.  I have had them try this on PDFs and Word Documents.
LVL 1
FirstcomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

colly92002Commented:
Try resetting your index and doing a full crawl.  You can do this from Central Admin.

Dy default, search results are returned as a raw URL, whereas browsing to a folder and opening a document from there is actually controlled by an active X control in the client, so if the full crawl does not help then its probably a browser setting.  Does it work on a Windows XP client?
0
FirstcomAuthor Commented:
Yes, it does work on a Windows XP client.  I had a user with restricted rights open up a PDF straight from the IE browser that a user in Windows 7 had to save the document first, before opening it.

Does this still mean that I need to reset my index and do a full crawl?  Are there instructions for doing this through Central Administration that you would recommend me following?
0
colly92002Commented:
The behaviour you describe can be solved by using the permissive file handling setting at teh Sharepoint web application level.
See:  http://sharepointsoldiers.wordpress.com/2011/11/03/permissive-mode-in-browser-file-handling/  For a full desciption on how to change this.
http://sharepointconnoisseur.blogspot.co.uk/2011/11/tips-to-resolve-sharepoint-2010-users.html

Please note that this can have security implications (although I  have permissive mode enabled in my farm and I'm not at all concerned).

I would expect changing this setting will cure you current behaviour without a requirement to reindex.

If you want to know why it's different in Win7 to XP then you need to run a security audit to determing what settings (probably in GPO) are different and causing this behaviour.  If you are not configdent in doing this, then there are Microsoft partner companies that can do this for you.  However I would stress that I run a farm with mixed clients, and run in "permissive" mode in order to support both, and I don;t worry about it.  It is an option if you absolutely want to cover all the bases and totally reduce risk to your organisation.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

FirstcomAuthor Commented:
I have checked the File Handling settings on both the webapp level & the one document library I know has an issue.  Both locations showed Permissive BrowserFileHandling.  This problem happens on both PDFs & Word documents for nonadministrative accounts.  When I click on the file, I get the three options "Check Out and Open", Open, and Cancel.
0
colly92002Commented:
I'm running out of ideas, but I'm pretty sure its your Win 7 client rather than SharePoint.
Reboot everything (including domain controllers), then reset the index and rebuild. (http://technet.microsoft.com/en-gb/library/ff621079%28v=office.14%29.aspx).

If that doesn't work its time to start auditing your setup on Win 7 as already suggested.  Have you tried diferent browsers?  I would recommomend trying Chrome.  If you are IE only, then compare the options between the browsers used in XP and Win7 (particularly  the version used).
0
FirstcomAuthor Commented:
I have not been able to reproduce the error on any Word documents.  The PDFs, I found a solution online that fixes it.

1. Open the registry.

2. Go to HKLM\SOFTWARE\Policies\Adobe\\\FeatureLockDown.

3. Create a key called cSharePoint.

4. Create a DWORD value called bDisableSharePointFeatures.

5. Set its value to 1.
0
FirstcomAuthor Commented:
My answer resolved the problem.  Expert's suggestion was a good suggestion and deserves acknowledgment.
0
colly92002Commented:
Thanks for posting your solution - I've added this to my knowledge base :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.