[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 113
  • Last Modified:

Problems configuring RSTP, key ports are set to the backup ports role

Attached is the current topology of our network.  RSTP is enabled on all switches except for the Core1 switch.  

All root priorities on the switches are set to 32768 except for the the 3 core switches indicated.  

When I enable RSTP on the core 1 switch(all ports) it sets all the ports to forwarding except for ports 2 and 4 which are going to core 2 and core 3 respectively.  

It sets the port roles on both 2 and 4 to backup port and blocks them.  

Core 1 and Core 2 are connected via a single Gbit line and Core 1 and Core 3 are also connected via a single Gbit line.  Any ideas appreciated.

Thanks.
RSTP.png
0
RHNOC
Asked:
RHNOC
  • 3
1 Solution
 
Don JohnstonInstructorCommented:
What you are seeing is very... unusual.  I have never seen a switch with a port in the backup role... ever.  Simply because a backup port is a port on a switch that is connected to the same segment as another port on the same switch.  This would require that these ports are connected via shared media like coax (RG-50 or RG-58) or a hub.  Not only is this unlikely (or even possible given the type of links involved) but it is inconsistent with your topology.

You don't indicate the make/model of the switches involved, but are the Core1, Core2 and Core3 switches from the same vendor?

The only variable consistent with the problem that you've indicated is the bridge priority. Have you tried changing the priority on Core2 and Core3 to 32768?

Prior to enabling RSTP on Core1, what do Core2 and Core3 show as the root bridge?
0
 
RHNOCAuthor Commented:
Core 1 is a TPLink TL-SG2424, Core 2 is a HP Procurve 3400 and Core 3 is a HP Procurve 2824.  I am trying to migrate off of the TPLink because the rest of my environment is HP.  The TL-SG2424 was put in place for a temporary solution(long story).  Enabling RTSP on it is not required to complete my goal, but It was more of a safety net and since RSTP is enabled on all my other switches I thought it would be a good idea.

I haven't tried changing the priority on Core2 and Core3 to 32768 before enabling RSTP on the TL-SG2424.  Unfortunately we are 24/7 so I can't play around with this too much.

Prior to enabling RSTP on Core1, both Core2 and Core3 say they are the root.  Also all of the other switches that are alone on their own segment off of the Core1 switch say they are root.  So I suppose the BPDU packets aren't passing the core1 switch when RSTP is not enabled on any of the ports.
0
 
RHNOCAuthor Commented:
I ended up abandoning this switch because of no resolution...
0
 
RHNOCAuthor Commented:
No resolution...
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now