Sage 50 Accounts 2014

Hi All,

I have a problem with a clients server, it appears a Sage update has caused a problem on the 2012 Server and will not allow me to install Sage on the server again, we are installing sage on the server so remote users can access.

The error part way though the install is attached, I have called sage support and they have asked me to try the following

- delete all the sage files and try again under a different directory
- logon as a different administrator and try the install
- download the installer from their website
- run sfc /scannow on the server

And still nothing. they are putting this error down to permissions but I am logged in as the admin.

Any ideas?

Ryan
error1.JPG
error2.JPG
ryank85Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bruce DenneySage 50 Consultant and IntegratorCommented:
see this

http://ezinearticles.com/?Windows-Installer-Error-1603---What-is-it-and-How-to-Fix-Easily&id=4468301

It could be a corrupt folder, so try installing to a different location or doing a clean reinstall following the instructions here.

http://support.makingithappen.co.uk/sage-50-guides/clean-reinstall.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ryank85Author Commented:
Hi,

Tried all this with no luck, sage support have no idea, they keep going back to the permissions but I know I have full access.

I have even tried starting the windows installer service as this was setup to manual start up.

Ran malware bytes scan

Ran sfc /scannow and this comes back ok with no errors

There is no anti virus software on the server causing to the block the access.

Anything else I can try, I'm puzzled, they have said removed .NET Framework from the server and re-install, when I check roles under management I can see 3.5 and 4.0 installed, can I remove these and re-install without causing more problems?

Thanks
R
0
Bruce DenneySage 50 Consultant and IntegratorCommented:
The clean reinstall I posted instructions for requires you to uninstall .net

If you don't follow the clean re-install instructions then you have not done a clean re-install.

Please take a bit of time and follow the instructions do a clean reinstall, there are lot of little odd files to delete, you may find some assemblies will not uninstall but do the best you can.

The alternative, is to reinstall the server OS and that is a big pain.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

ryank85Author Commented:
Hi Bruce

I have been onto Sage again and I am a little concerned about what they are telling me to do.

As per your link it says remove .NET framework. Sage has asked me to go into Windows Features and remove .NET 4.5 however when do I this I get following message, however if I remove this feature will it cause problems with everything else, i.e. active directory services/RRAS etc?

Ryan
Capture.PNG
0
Bruce DenneySage 50 Consultant and IntegratorCommented:
I understand you reluctance, but if .net is broken it has to be fixed.

you could try the MS repair tool
http://www.microsoft.com/en-gb/download/details.aspx?id=30135

There are some "last ditch" tools out there to clean up and fix broken .net installations.
http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx
I have used them in the past and they have worked on some occasions and not on others.

Uninstall and reinstall is the way that always works to fix these things.

Perhaps just uninstalling and reinstalling the 4.5 updates might work.  
One has to assume that out of the box .net would have been working as it is integral to a lot of things in Server 2012 and it is an update to it that has not install properly or gone wrong.

I suspect that whilst things might break when you uninstall .net they will work again after reinstalling.  
Perhaps we could see if there are any .net experts out there who could offer some additional input as that is where this issue has led.
0
ryank85Author Commented:
Thanks Bruce. I will try the fixes tomorrow and if that doesn't work I will reinstall over the weekend.
0
ryank85Author Commented:
Hi Bruce

I tried the repair from the above link and that didn't work. I had Sage Support dial into the server and they have told to me log on to the server as local administrator and remove .NET 4.5 from Roles and Features and then try and resinstall Sage again as this install .NET 4.0 from the installer. They have also mentioned that removing 4.5 from the server will not cause any problems as per the image in the earlier post?

They said it makes a difference when installing from the local admin rather than the domain admin? is that right as I don't know the local admin password

I could reset using this guide I guess
http://www.kieranlane.com/2013/09/18/resetting-administrator-password-windows-2012/

Ryan
0
Bruce DenneySage 50 Consultant and IntegratorCommented:
Yes, Local Admin is NOT the same as Domain Admin (even though domain admin appears to have local rights).

You really don't know the Local Admin password?  Did someone else  set the Server up and not record it?

You had a look to see what local admins exist?  Tried common passwords - blank password/domain admin password/old admin password?

Can you create a new local admin user as domain admin?
0
ryank85Author Commented:
I setup the local admin with the same password as the domain on setup and that doesn't work for some reason. Strange I know. Hence why I need to change password for create new local admin account. Can I do this from the command prompt net user admin1 Password123 for example then add them to the admin group?
0
Bruce DenneySage 50 Consultant and IntegratorCommented:
I have no idea, try it and see.
0
ryank85Author Commented:
That command only amends the domain admin user.  

After further investigation the server I have doesn't have local admin as it's a domain controller. Therefore I have been told the domain admin is fine to remove the .net from the server.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.