Solved

SCVMM 2012 error 2940

Posted on 2014-07-31
6
92 Views
Last Modified: 2015-10-26
In my SCVMM environment I can't recently push any VM from a templates on any of my Windows 2012 core Hosts.
Always getting error 2940 VMM is unable to complete the requested file transfer. The connection to the HTTP server.....

Firewall are open and windows firewall is disable but I did realise that for some reason i don't see port 80 listening on any of the Hosts when running a netstat -an

everything was running fine 2 weeks ago. Can anyone help?
0
Comment
Question by:SupportCGI
  • 4
  • 2
6 Comments
 
LVL 12

Expert Comment

by:David Paris Vicente
ID: 40231462
Hi,

You could try the steps from another EE question here

The problem is very similar.

Let us know if help.
0
 

Author Comment

by:SupportCGI
ID: 40232285
Saw that post and already tried and validate everything the mention.

I know SCVMM is not the issue since I can deploy VM on other Hyper-V clusters.
It really 5 cluster of 35 Host out of 68 that stop working 2 weeks ago and i'm clueless why.
0
 
LVL 12

Expert Comment

by:David Paris Vicente
ID: 40233788
Hi SupportCGI,

You should double check Firewalls, NIC, Teaming, DNS because this is something messing with the protocol.

Can you issue this commands and check the output:
netstat -ano | findstr ":80" and also for ":443"

netsh http show servicestate

Open in new window

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:SupportCGI
ID: 40234745
I found the problem but still looking for a solution.

Problem:
The wrong library was trying to access the hosts in that specific Host group since its block at the firewall I have error 2940.

Cause:
In my libraries property the right Host group are assign to each library but the hierarchy is messed up and dont match the one I have under my Fabric or my VMs and Service that are always the same.
Host groups are child or parents of different Host groups. I even have Host groups outside The All Host.

how can that be and how can I fix this?
0
 

Accepted Solution

by:
SupportCGI earned 0 total points
ID: 41078249
by the way
the problem was my equivalent objects.
Some were missing.
0
 

Author Closing Comment

by:SupportCGI
ID: 41117027
Since have 9 librairies dedicated to specific Host group, Since some equivalent objects were missing.
The wrong librairy was trying to server a host group he cant access because of the network.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When we have a dead host and we lose all connections to the ESXi, and we need to find a way to move all VMs from that dead ESXi host.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question