Exchange 2010 new ssl cert not including *.local server name

Since new ssl cert requirements are not allowing the servers local names to be included I have run into a few issues.  I have followed the posts that go through the Exchange Shell and make the following changes for the .local changes:

Set-ClientAccessServer -Identity “server-name” –AutodiscoverServiceInternalUri https://”mx-record name”/autodiscover/autodiscover.xml

Set-WebServicesVirtualDirectory -Identity ““server-name”\EWS (Default Web Site)”-InternalUrl https://”mx-record name”/ews/exchange.asmx

Set-OABVirtualDirectory -Identity ““server-name”\oab (Default Web Site)”-InternalUrl https://”mx-record name”/oab
1.      
2.      Open IIS Manager.
3.      Expand the local computer, and then expand Application Pools.
4.      Right-click MSExchangeAutodiscoverAppPool, and then click Recycle.


Since then the clients are getting multiple errors in Outlook.  First is a cert error that initially points to their mx-record name and then they get one that is coming from their firewall...  The next issue is that they can no longer activate the Out of Office assistant from outlook either.  They are getting the server is unavailable..  That started after I completed the above changes...  OOF works from OWA..
infospecsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
are you using split dns?

Windows - Setting Up Split DNS
http://www.petenetlive.com/KB/Article/0000830.htm

in other words, do you have a local dns zone for your external domain pointing to your internal servers so that they can resolve as .com instead of .local internally as to match the certificate and configured exchange URLs?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
infospecsAuthor Commented:
That looks like it fixed it....  Thank You...  I should have thought about that..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.