RDP Disconnect Problem with W8.1

Problem with RDP to workstation through SBS2011.

I have a problem with Remote Desktop disconnecting after about 45 seconds with Windows 8.1 workstation(worked fine with windows7).

System: Window 8.1 upgrade from 8.0 early retail
-Would not connect at all but I could see the computer through SBS2011 panel remotely and would try to connect with Computer not found.
-downloaded all Microsoft's  latest and greatest updates.
-Can RDP through SBS2011 but drops connection after a bit.

Will stay connected if I RDP to server2011 and RDP to the workstation through the server.

Thanks is advance for you help before I go back to windows 7 on this workstation.
SCE
sceserAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gary PattersonVP Technology / Senior Consultant Commented:
45 second timing matches this, and I've seen it resolve similar issues:  http://support.microsoft.com/kb/2897602

If that doesn't work, I'll note that this is a problem that appears to have multiple possible causes - you might want to review this thread and look at the several things that have worked for other users who had this problem.
0
VishalnarseSystem Wintel Administrator L2Commented:
Hi,

 I request you to please applied the Hotfix and also try free Windows Admin Tool Kit Click here and download it now: http://www.intelliadmin.com/index.php/network-administrator-tool-kit/

The issues started when switch to a different NIC, rdp to server 2012 drops every 40-60 seconds.
0
sceserAuthor Commented:
The problem is still current. None of the solutions solved the problem. All microsoft updates have been install on the SBS2011 server and the 8.1 machine.  It disconnect after one minute and wants to debug with VS. Stays connected locally rdp the server than rdp into the w8 machine. If I log into SBS2011 panel and select computer it logs on  and disconnects after one minute. I will try removing printers to see if it helps.
0
sceserAuthor Commented:
Problem SOLVED. To anyone that has this issue, get rid of all printer drivers and reload the ones you need one by one until you find the culprit! It could also be caused by a Bluetooth device trying to link across the  remote. I would have never Guessed!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.