Microtek scanner not being recognised by software

I have a MIcrotek ScannerIIsp installed on a windows 7 home premium system (32bit). Using an Adaptec 2920c SCSI card. All drivers for the SCSI are installed and also for the scanner (surprised they still had them). Unfortunately the scanner program(s) don't recognize that the scanner is there. Under Device manager everything shows ok. I'm thinking that I'm missing a twain compliant driver somewhere. Any ideas?

Thanks Richard
RichardPWolfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dbruntonCommented:
Try Vuescan http://www.hamrick.com/vuescan/microtek_scanmaker_iisp.html

Free to try.  If it works then purchase.

I do recommend Vuescan myself.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MereteCommented:
RichardPWolf,
Which model is it?
3800, 4900, 5700?
SCSI to USB maybe the way to go so your software will recognise it.
No need for any drivers either as USB is plug and play and windows installs the drivers fro USB.
http://www.psism.com/usbxpressscsi.htm
USB Serial converter
So when you open the scanner software such as?
I have a Cannon Printer / scanner pretty old model and it works fine in windows 7 x 32 bit. As it uses USB all I had to was install the Cannon Utilities.
TWAIN is not a hardware-level protocol; it requires a driver called Data Source for each device.
Which model do you have
http://ww1.microtek.com/Mii/Web/Support.php
0
dbruntonCommented:
He has the IISP model.

This link http://www.microcentertech.com/tech_center/DB/read_article.php?faqid=./Info/INF5001591D.htm may help.

Also http://download.cnet.com/ScanWizard-v5821_alldisk-exe/3000-18492_4-157960.html  The ScanWizard may also help but I can't vouch that.

But try Vuescan first.  The link I supplied above says it works.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

RichardPWolfAuthor Commented:
Thanks, will give it a try and post back.
0
RichardPWolfAuthor Commented:
OK, Vue Scan worked perfectly. Scan wizard sees the scanner but reports not ready. I'm wondering if it could be because of the SCSI card. The card works great with VueScan and I can see the scanner in the scanner and camera mmc of windows and it passes diagnostics. This scanner is going to be donated to a church so I'm trying to find a no cost/low cost solution. Thanks so far. Will post back on what I've found.
0
RichardPWolfAuthor Commented:
Worked great first time. Thaks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.