Configuring a Cisco switch from Base line Configuration

i required to configure a Cisco Catalyst switch in to  already functioning network in a branch office .  
i am accepted to get baseline configuration from , from head office .  kindly guide me  ,  how can i use this baseline configuration and easily configure the switch .

Like i assume, the baseline configuration may come to me in a text file , i may just copy the same text file to hyper terminal  and may change some parameters as it is in,   other switches at that branch. and just run and save .

Kindly give me some hints on details ,  that i may  have to ask to head office IT department , who may give me the "Base line Configuration".
if possible  give me a sample baseline configuration , so that i can tray on some switches .

any inputs is highly appreciated ,and thanks in advance
FiruITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkinsdNetwork AdministratorCommented:
Open the text file
Use Ctrl-A to select all the content

log in to your switch
conf t
Right click to paste the configuration
save the configuration file
0
FiruITAuthor Commented:
Dear Akinsd  ....

is it that simple....?

don't i have to make some changes....?
i know you can only guide me exactly what changes to make,
  if only  i may provide you the "base line configuration" and configuration of any Cisco Switch already working at that site.

But by any chance is it possible,  for you to list two or three mostly changed parameters , or in other word
give me name of two or three details that i can take from , Other switches that is working at that site , and edit  baseline configuration to suite to the environment .
0
AkinsdNetwork AdministratorCommented:
The basic things you will change are
- hostname xxxx
- ip addresses of interfaces
- switchport assignments

These usually would be left out in baseline configuration and configured separately but just in case they are there, then you'll need to customize them for the switch.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

FiruITAuthor Commented:
Dear all ,

if it is not big trouble ,
kindly add some more topics that one may have to change on Baseline configuration ,usually .from your experience

OR  Kindly if possible show me a  baseline configuration  from your side ........and show me how you may change the parameters on the same. from a typical baseline configuration you might haves worked recently

thanks for all guidance in advance
0
AkinsdNetwork AdministratorCommented:
Base Configuration sounds like  big terminology but all it means is "Template"

Every organization will have unique configuration.
The purpose is to minimize typing.
Imagine having to type the same commands over and over on multiple switches. A Base Configuration takes care of that. It is not universal, but unique

Here is a sample of 1 of many Base Configurations I use. I replaced specific information with ".....scrambled....."



!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
enable secret level 1 5 .....scrambled.....
enable secret 5 .....scrambled.....
!
username Administrator privilege 15 secret 5 .....scrambled.....
no aaa new-model
clock timezone UTC -8
clock summer-time UTC recurring
ip subnet-zero
ip domain-name .....scrambled.....
ip name-server .....scrambled.....
!
no aaa new-model
ip subnet-zero
ip routing
ip domain-name .....scrambled.....
ip name-server .....scrambled.....
ip name-server .....scrambled.....
!
vtp domain .....scrambled.....
vtp mode client
!
cluster commander-address .....scrambled..... member 7 name .....scrambled.....
!
.....scrambled.....
  quit
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
 
!
interface Vlan1
  no ip route-cache
!
interface Vlan8
 no ip address
!
ip classless
ip http server
ip http authentication local
ip http secure-server
!
!
snmp-server group IS v3 noauth read .....scrambled..... write .....scrambled..... notify .....scrambled.....

ip default-gateway .....scrambled.....
ip classless
ip route 0.0.0.0 0.0.0.0 .....scrambled.....
ip http server
ip http authentication local
ip http secure-server
!
!
snmp-server community .....scrambled..... RO
snmp-server community .....scrambled..... RW
!
control-plane
!
!
line con 0
 logging synchronous
line vty 0 4
 password 7 .....scrambled.....
 login
line vty 5 15
 password 7 .....scrambled.....
 login
!
ntp server .....scrambled.....
end
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FiruITAuthor Commented:
Great Support , thanks
0
AkinsdNetwork AdministratorCommented:
You're welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.