tar restore loses ACL settings

I recently restored a folder from a tar archive. This folder did have extended ACL settings, but after the restore they are gone. How  do I fix this? Is tar not the right tool for saving these extended settings?
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
The extended ACL is stored else where and not part of the file reference.
To deal with archive while retaining the extended ACL settings, you would need to use getfacl to extract the extended acl settings into a file that will the be used following the restore to reapply the ACL permissions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
That's what I was afraid of. I installed Samba4 as a DC/AD and implemented redirected folders. These folders were under /redirectedFolders/Users. The user files had ACL settings. Is there any why to know what these settings were or do you think I'd have to re-do the redirectedFolders from the beginning?
0
arnoldCommented:
Usually redirected folders have user ownership only unless you would like Administrators to have access as well.
You could setup a cron that would periodically run setfacl recursively the permissions to allow for group access.

Did you have those users id mapped? Or are all the permissions set to smb ownership?

Though. For smb, the settings are stored within smb.conf which arbitrates the access.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jmarkfoleyAuthor Commented:
smb.conf has the top-level folder configured:
[Users]
    path = /redirectedFolders/Users
    comment = user folders for redirection
    read only = No
    writable = yes

Open in new window


but the users' sub-folders are created by AD Group Policy and extended ACL permissions are create automatically when the user connects to the domain from the Windows workstation.

I guess I'll try removing the user subfolders and see if the get automatically created. I'll let you know.

Since the folders are created
0
SandyCommented:
if you have created tarball along with using --xattrs then it will restore else will not.

TY/SA
0
jmarkfoleyAuthor Commented:
Sandy: --xattrs is not supported by my tar (1.26)

Arnold: I believe I've re-set the extended permissions via WIN7, although I still might have some permission issues I'll address in a separate topic.

Going forward - I'll save the ACLs separate using `getfacl -R /thisdir /thatdir >backupACL.txt`, and back that file up with tar. There are getfacl,  getfattr, setfacl, setfattr commands. I'll have to check the man pages to see what the differences are.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.