Browser error "Malformed certificate" = Google Chrome (v36) and IE (v8) - with a root CA SHA256

Using Google and IE to connect to a URL we get an error :-
The certificate that Chrome received during this connection attempt is not formatted correctly, so Chrome cannot use it to protect your information.
Error type: Malformed certificate
Subject: mycert.testing.com
Issuer: GlobalSign Organization Validation CA - SHA256 - G2

The server is running WIndows 2003 server and the version of browsers as stated above. So on a development 2003 server I ran Windows updates and re-tried and the issue was resolved. I need to fix the issue on live 2003 servers but I do not want to run the complete Windows Update in case it breaks many other functions.
I am assuming there was an upgrade to support  new hashing algorithm SHA256 ?
Appreciate if anyone can shed light on this and more specific on what needs updating.

Thanks
ccfcfcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
Look for the Root Certificate Updates and see if that fixes your problem.
0
ccfcfcAuthor Commented:
I am still struggling to find anything that fixes the issue. There seems to be a common theme with the SHA256 in the certs needed within Windows 2003. I fixed the issue by running Windows updates on the 2003 server but this tkes over 4 hours and there are many. My other issue being, this is a live server running apps and web sites and it woudl break other apps and be down for 4 hours.
SO I am not ure what Root Certificate as part of the update is required. I woudl be grateful if you know what update is required.
I found this link http://support.microsoft.com/kb/968730
But when I download it and attempt to run it, it says " but is for a machine other than the current machine" so does not run .
0
Dave BaldwinFixer of ProblemsCommented:
See if the info here helps any:  http://support.microsoft.com/kb/931125
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ccfcfcAuthor Commented:
YEs I found that one and applied it made no difference. I even got the new RootCA Intermediate CA and imported into the Server Certificate MMC made no difference. I have been sent a knowledge base KB968730  

Applied it , re-booted and it seemed to have fixed my problem. I am going to have to do some more testing on other server
0
ccfcfcAuthor Commented:
Yes it seems to have solved the problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.