Testing an ASP File on IIS 7.5 running on a Windows 2008 Server

I am attempting to open some very basic ASP Files in Internet Explorer 8 on a 2008 Server. I have followed various deployment how to links, but when I type in the URL in explorer, I receive a HTTP Error 404.0 Error. This is what was typed in for the URL:  http://localhost:85/webfiles/testasp.asp
Rick RudolphAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John MoshayemCommented:
Hi,

Are you check permission to file in this directory? in basic step you must check the permission of this file, maybe you put it via administrator and other group like "Everyone" group dont have a permission to view this file.
0
sammySeltzerCommented:
Your problem could be one of two reasons.

1, make sure that asp is installed.
It is no longer installed by default.

To install it,
 •Go to control panel
•click program features
•turn windows on and off
•go to internet services
•under world wide web services check the asp.net and others

2, If it turns out that asp is already installed, then follow these steps to ensure it is enabled.

1.Click Server Manager
2.Add roles and features
3.Click next and then Role-based
4.Select your server
5.In the tree choose Web Server(IIS) >> Web Server >> Application Development >> ASP
6.Next and finish

I bet that if you create a .html file in that folder and run it like
http://localhost:85/webfiles/testasp.html

it will display the contents of that file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
are you usiing port 85 as your port in your website? by default it's set to 80.

if it's using the default port, you should be able to access it like this:

http://localhost/webfiles/testasp.asp
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Applications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.