Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

IIS 7.0 Directory Browsing for virtual directories throwing error if set to disable at default web root. Is there a workaround?

Avatar of kdschool
kdschool asked on
Microsoft IIS Web ServerWindows Server 2008
4 Comments1 Solution313 ViewsLast Modified:
Policy requires me to set my web directories to not allow directory browsing.  If I do this at the default web directory I cannot change it in II7.0 for my virtual directories.  It throws an error.  The error shows the path to the folder and says cannot write configuration files.  it works fine in I.E6.  Also I can change any folder on the server to enable it and that works.  The virtual directories work fine if it's disabled at the default web root.  I have to allow these directories to accept directory browsing like on the old server while leaving all the other off.  Any help would be appreciated.

I can do it if I go back and individually deny directory browsing on each folder but there is a lot of work involved in that and I still can't do the root directory itself since it does not show up in IIS interface like it does in the NT file structure.
ASKER CERTIFIED SOLUTION
Avatar of Pushpakumara Mahagamage
Pushpakumara MahagamageFlag of Sri Lanka imageVP

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answers