Aptana IDE installation Error

I installed Aptana IDE and when I tried to open it, I got the following error below.  Any ideas on how to fix?

Aptana Error
LVL 5
IsaacSharePoint Client Side DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

c lCommented:
i would un-install it, make sure all of the files are gone, and then re-install it. when re-installing, make sure you're doing it as an admin
0
IsaacSharePoint Client Side DeveloperAuthor Commented:
I uninstalled as you suggested and re-installed as admin but I still get the same error "verify.dll" is missing.
0
c lCommented:
doing a quick google search, I came across this post to add a path to your system PATH variable

http://www.theinsanetechie.in/2013/08/verifydllmissing.html
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

c lCommented:
do a search for verify.dll on your system and add the location to the PATH variable described above
0
IsaacSharePoint Client Side DeveloperAuthor Commented:
That's odd..verify.dll does not exist on my system.  Is it installed on all systems by default?
0
c lCommented:
that I'm not sure of, but you can download it from the link below:

http://www.dll-files.com/dllindex/dll-files.shtml?verify
0
Bernard S.CTOCommented:
On my sytem it is i  directory /jre/jbin under Aptana:
C:\>dir verify.dll /s /p
 [...]

 Répertoire de C:\Program Files (x86)\Aptana Studio 3\jre\bin

03/02/2011  06:39            31 744 verify.dll
               1 fichier(s)           31 744 octets

     Total des fichiers listés :
               1 fichier(s)           31 744 octets
               0 Rép(s)  [...]

C:\>

Open in new window


My Aptana version is   Aptana Studio 3      3.4.2.201308081805-08082013180610

Seems verify is somehow related to Java http://systemexplorer.net/fr/file-database/file/verify-dll/8644191 so if unistalling and re-installing Aptana does not work, I would suggest the following path:
1 - Use Ccleaner from http://piriform.com to slightly clean your registry base (be careful though; on first run against registry base do not select all checks at once, but ad them one after the other and check yourself that the proposed cleanup looks fair!)
2 - Use same Ccleaner to uninstall if not yet done, ther re-run registry cleaner
3 - Re-download Aptana, reinstall. If not ok, uninstall AND UNINSTALL JAVA if present. Reinstall Java from http://java.com/fr/download/manual.jsp, THEN reinstall Aptana

Sorry this looks like lot of work... but seems you have no choice!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bernard S.CTOCommented:
B-) Glad we could help! Thx for the grade and points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.