SQL Server 2008 R2 Cloning in VMware

Today I have followed the steps below to clone a Windows Server 2008 R2 Server running SQL 2008 on VMware 5.5

1. On the SQL Server to be cloned, renamed all SQL Services to Local System, made them manual and stopped them

2. Rebooted SQL Server to be cloned and then shut down ready for a cold clone

3. Cloned SQL Server using Guest Customization

4. Powered new SQL Clone on, checked networking and hostname and joined domain. All drives working fine for Logs and Data etc

5. Rebooted new SQL Clone

6. Gone to Services.msc and changed all services to the Windows AD Service accounts they were.

7 Tried to start them and each one says "Windows could not start the SQL Server (MSSQLSERVER) Service on Local Computer. Error 2: The System cannot find the file specified" I also cannot run SQL Server Configuration Manager. It says MMC could not create the snap-in. The snapin might not have been installed correctly. (It was definitely working on the machine we cloned from fine)

8. Tried googling but there are so many different issues, it's very difficult to find one which corresponds to this issue. We know the passwords are correct. I don't know if its worth running through a SQL Repair but would rather avoid if anyone has had experience of this

9. There is a MS link but I think you need to actually be able to run a query MSSQL Management Studio.
LVL 2
rhiancohenVMware Senior ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Personally, I would not recommend CLONE-ING an SQL installation for Production Deployment, it's high risk if the SQL server does function correctly.

We just Deploy from template, or Clone from template standard images, e.g. severs that are fully patches, with the SQL Prerequisites, we then Deploy SQL, Sharepoint using scripts and unattended installations.
0
rhiancohenVMware Senior ConsultantAuthor Commented:
Yes I think you're right. I've tried a hot and cold clone now and both with the same problem.

Do you mean you have a standard O/S template with everything ready to go, deploy from it then install SQL etc.

We have standard O/S templates which is fine. Looks like it would be best to do that
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Do you mean you have a standard O/S template with everything ready to go, deploy from it then install SQL etc.

Yes, that's it exactly what we do.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

rhiancohenVMware Senior ConsultantAuthor Commented:
OK Quick Update.

I found the reason it didn't work.

On the VM we were cloning from the drives were mapped

C:\O/S
D:\SQL Install
E:\SQL Databases
F:\SQL Logs

but when it cloned the VM, the clone re-arranged the drive mappings. When I put them to the correct ones and rebooted, all the services started fine and I can access SQL Management Studio using the new cloned name.

I still think there may be a few more things that may not work as expected but thanks very much for your quick response earlier
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I'm not sure why, you drive letters are changing you CLONE.

Are you using OS Partitions or Virtual Disk Drives for each D:, E: and F: ?
0
rhiancohenVMware Senior ConsultantAuthor Commented:
Separate Virtual Disk Drives on separate SCSI Controllers as well. (0:0, 1:0, 2:0, 3:0 etc)

Just changes the clone. The original SQL VM is fine.

Strange I know!
0
rhiancohenVMware Senior ConsultantAuthor Commented:
This solution worked for us with the drive mappings allowing us to start the SQL Services. We obviously need to test this for the rest of this week but appreciate that templates, scripts and unattended installations are a better automated way to go.

Also found a good product called Delphix Database deduplication which can solve some of the issues where developers want quick copies of Databases. Created by the guy who developed Avamar.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.