how do I run executable programs from network share?

I have mapped \\fs1\vol1 to drive w:

In Windows 8.1 & Server 2012R2, if I try executing program directly from the network via w:\prog\program.exe I get "Access is denied"

I can run the program from Windows Explorer, however I want to be able to run programs via batch file.

I am looking for a Registry Entry or command to allow this to work.

I am primarily interested in running executable programs, however I find it interesting to note that I cannot do a "start w:\1.txt" in Windows 7, start w:\1.txt would open the text file in notepad.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I can only guess, as this works in 8 with default Settings as it did in 7...
Do you start that command Shell elevated? Because an elevated shell will not have access to the same Network drives as the user has.
johnschmeroldAuthor Commented:
Elevated & non-elevated users have the same drive mappings, I have implemented following on all my machines:
reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /f /v EnableLinkedConnections /t REG_DWORD /d 1
Now that is fine... but is that the problem, do you use the command Shell elevated here? That was what I tried to find out.
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

johnschmeroldAuthor Commented:
Same issue from elevated or un-elevated shell.
Ok, this is not normal. Our whole company runs 8.1 and we don't see that problem.
Please monitor the process of starting that executable with procmon and look if it's really an access denial.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnschmeroldAuthor Commented:
Not sure why it hasn't come up before now, but it turns out in order to prevent this behavior on a Samba share, the execute bit needs to be set. After running chmod -R 0770 /samba/vol1/ on the server, I edited smb.conf's service definition to look like this:
path = /samba/vol1
valid users = @smbgrp
write list = @smbgrp
guest ok = no
writable = yes
browsable = yes
inherit permissions = yes
directory mask = 0775
create mode = 0770

I am still having a curious problem with permissions, specifically, when I create or copy a file to the server the group execute bit isn't being set, so if I run "echo hello world > 3.txt" from a dos prompt, Samba isn't setting group execute: -rwxrw----. 1 john john   13 Aug  7 06:50 3.txt

This problem is for another thread. You have solved my problem. Thank you.
A samba share... now that is something worth mentioning the next time :)
johnschmeroldAuthor Commented:
Thanks for your help. Looks like I am going to need to do some permissions homework. inherit permissions = no solves the problem, but I suspect it is an incomplete answer.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.