We help IT Professionals succeed at work.

Check out this week's podcast, "Dairy Farms to Databases: Community's Hand in Technology"Listen Now

x

Exchange 2010 public folders and permission

Harold
Harold asked
on
260 Views
Last Modified: 2014-08-07
We have folders that were already setup and I added a new user to Exchange and assigned him permissions to folders as needed. There are 3 that WILL NOT let him see below the parent folder. I have removed and added back, 3 times with no change.

What am I missing?
Comment
Watch Question

imkotteesSenior Messaging Engineer

Commented:
Is he able to see the parent folder?

Is he part of any other group which has reviewer access to those PFs?
HaroldNetwork Engineer

Author

Commented:
imkottees: He can see the parent w/content and SEE the subfolders, just not content. He has Editor permissions.
Senior Messaging Engineer
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
HaroldNetwork Engineer

Author

Commented:
I did for the one user, but I really don't want to remove EVERYONE, this was unfortunately setup without groups
imkotteesSenior Messaging Engineer

Commented:
was it working for that one user
HaroldNetwork Engineer

Author

Commented:
no that is the one I created this question for

for kicks, I added myself, which I did not have access and I got access immediately. Now I see what all the other users assigned there see.
Murali ReddyExchange Expert

Commented:
Did you tried giving the access from EMS

Get-PublicFolder "\PFIdentityPath" -Recurse |Add-PublicFolderClientPermission -User "UserName" -AccessRights "AccessType"

Something like-


Get-PublicFolder "\MyTestPF\PublicFodler1" -Recurse |Add-PublicFolderClientPermission -User "TestUser1" -AccessRights "Editor"

preferably run from the server hosting the public folder database.
Murali ReddyExchange Expert

Commented:
Can you also check the current access part by running..

Get-PublicFolder "\PFIdentityPath" -Recurse |Get-PublicFolderClientPermission

.. and see if the granted access does exists for the users.
HaroldNetwork Engineer

Author

Commented:
imkottees: I had been removing from the Parent folder then, just adding it back, which had no affect. Today I removed permissions from Sub-filders back to Parent, then added back and this worked. I don't understand why but at least it is fixed.

Thank you
imkotteesSenior Messaging Engineer

Commented:
Good to know that, happy ending ;-)

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.