Cannot install Oracle JDeveloper on Windows 7, "CMD property not found in autorun.inf"

I'm trying to install Oracle JDeveloper 12c on Windows 7 but I get the error "CMD property not found in autorun.inf", when I run the file directly.
CMD property not found
If I run it from Oracle Installer (as Administrator), I get "corrupt" file, but I think this is misleading.
JDdeveloper corrupt file
googling this seems to always point to here, which says
CMD property not found solution
Previously, I had a compatability issue when installing Oracle Developer (Forms, Designer, Reports, and JDeveloper10g), I fixed that by saying it should be run as if on Windows XP SP2, and that did the trick. But I didn't see anything like this via google search.

Note: I have JDK 7 installed, and I've reviewed the Install instructions.
Gadsden ConsultingIT SpecialistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gadsden ConsultingIT SpecialistAuthor Commented:
Note: I downloaded Java edition (not Java Studio). It wasn't an install, it just unzipped everything, and there's jdeveloper.exe, I clicked on that and up opens Oracle JDeveloper 12.1.3.0.0. It looks good but doesn't have all the bells and whistles of JDeveloper Studio.
JDeveloper Java Edition screen shotI would still like to get JDeveloper Studio Edition loaded.
0
David Johnson, CD, MVPOwnerCommented:
I downloaded it (java not on this machine) right click run as Administrator and it installed perfectly all 1.8G of it. http://youtu.be/z_MX9oLmjcM
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gadsden ConsultingIT SpecialistAuthor Commented:
David,

thanks for the nice video ! but it's still not working . . . I'm going to try on a third machine.

I was able to load Java edition (not studio), so I think my machine is ok.

I have also been wrestling with this on an Oracle board, no one seems to have the answer to the problem directly, it's just "try this", "try that", etc.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Gadsden ConsultingIT SpecialistAuthor Commented:
It's loading now on my third machine (Windows 7 Home) !

I'm also going to try on Windows 8

will let you know.
0
Gadsden ConsultingIT SpecialistAuthor Commented:
Got JDeveloper Suite loaded on windows 8 machine as well :-)

So something is obviously wrong with the two machines, although they both have other Oracle software and other non-Oracle software, both running Windows 7 Enterprise. Plus I have Oracle JDeveloper via Oracle Developer on one of the machines, and JDeveloper Java (not "Suite") on the other machine.

But could never get any direct insight into the core issue, "CMD property not found in autorun.inf".

But thanks for your advise and video.
0
Gadsden ConsultingIT SpecialistAuthor Commented:
I didn't really get the problem solved based on the error message, I moved to other machines and got JDeveloper Suite loaded. So the issue is my machines, but both have other Oracle software running . . .
0
MehtaJasminCommented:
The accepted solution's video did not work.

Below steps worked for me on Windows 7 Enterprise.

1) Installed JDK 1.7.0_75 Windows 64 bit and pointed my JAVA_HOME to that folder.
2) Extracted jdev_suite_121300_win64.exe to jdev_suite_121300_win64 folder. It creates 'Disk1' subfolder.
3) Give following commands after that, make sure open the cmd.exe by 'Run As Administrator'

C:\Windows\system32>cd C:\jdev_suite_121300_win64\Disk1

C:\jdev_suite_121300_win64\Disk1>java -version
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)

C:\jdev_suite_121300_win64\Disk1>java -jar install/modules/ora-launcher.jar DISK
CNT=1 JRE_COMPONENT=oracle.jdk;oracle.jre
0
Gadsden ConsultingIT SpecialistAuthor Commented:
MehtaJasmin,

thanks for the follow-up. I will try your solution, but I won't be able to do so until next week. I'll make a note to give it a shot.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.