Mitel 5330e phones stuck on DHCP server message

We have a remote Mitel 5330e phone that has access to our Call Server via our layer 2 VPN tunnel.  The remote site only has 1 VLAN and it's the default VLAN.  We used the DHCP config helper to build option 125 and it still can't get an IP address.  The headquarters where the Call Server is uses VLAN 20, however, I'm able to access the Call Server from the default VLAN 1 on the remote network just fine..  So..  This is why we used the default VLAN ID of 1 on the DHCP config builder.  But..  The remote phone still can't get an IP address.  The desktop computer that is plugged into the phone can..  Any ideas?
gopher_49Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PhonebuffCommented:
My guess, is your remote phones are pointing at an IP for DHCP servers that it can not reach on the default configuration.  

It probably should be getting it's information from the same DHCP server as it's downstream stream PC is, then being assigned over o the Voice VLAN.
0
gopher_49Author Commented:
We typically don't use the DHCP server from the remote network.. We have a DHCP server at each remote facility.  This way if the VPN is down we can still issue DHCP.

I'm thinking we need to tag it for vlan20 for the remote SIP server is on vlan 20 and all of it's phones register using this vlan, however, I'm able to access the server from the remote network via the default untagged VLAN.  Something tells me the Mitel option 125 is expecting a tagged switch port for it can't even get an IP address from the local DHCP server.
0
Andy CantuCommented:
What VLAN is the switchport on where the phone and chained PC are connected?

What DHCP server are you trying to use for the phone?  What DHCP server are you using for the PC?

Can you post the Option you have configured on the DHCP scopes?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

gopher_49Author Commented:
They are plugged into a untagged port.  The workstation gets an IP address from the local DHCP server and can ping the remote Mitel server...  The phone doesn't get an IP address.  

We have a Sonicwall firewall issuing option 125.  I tried leaving the vlan option 125 field blank but it wants something in it.  I assume any value entered into this field assumes your switch port is tagged for it.  I would prefer to have it untagged for the default vlan ID 1.
0
Andy CantuCommented:
Can you post the string that you've configured in the option?

example: id:ipphone.mitel.com;sw_tftp=10.188.14.2;call_srv=10.188.14.2;dscp=46v46s26;vlan=20

You should try just putting 1 in the VLAN field and see if that works.  Most switches will accept a tagged packet, if the tag is the same VLAN they're on.
0
gopher_49Author Commented:
We're resuming this project on Monday.  I'll post the DHCP record then..  I think part of our problem is that the phones really need to talk to VLAN 20..  But.  The remote SIP server is through a layer 2 VPN.  I really don't want to deal with passing 802.1q across the layer 2 VPN.  To me that shouldn't be required as long as each network can see each other.
0
gopher_49Author Commented:
Andy,

How do we put the 5330e in teleworker mode?  Also, what ports need to be open?  And can we access the phone switch via it's internal IP when using teleworker mode?  The phones will be on the VPN.  Also.. Do we need to do anything special to the extension to allow Teleworker mode?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gopher_49Author Commented:
Putting it in Teleworker mode is the suggest method and disabling DHCP options.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.