Active directory User "log on to" probem

Hi

I have an interesting issue with a new 100 seat site we've taken over. The problem is when new users are created in AD under properties/account/log on to   its always set to "THE FOLLOWING COMPUTERS"
This prevents the user from logging into thin clients & some other machines, Now i can change this option to "ALL COMPUTERS" but this option seems to change back over night....
I cannot see any GPO's settings that could make this change back? Any suggestions would be helpful
I might also mention some admin accounts when newly created cannot log in to some computers also, but when left for a week or two they seem to come right.

Capture-Issue.PNG
LVL 1
Thomas NZSystems EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sekar ChinnakannuStaff EngineerCommented:
You can get the settings under Computer Configuration > Policies > Security Settings > Local Policies > User Rights Assignment. Using this option you can create a policy and set allow\deny logon to computers
0
SreRajCommented:
Hi,

This could be because of a script running as part of a scheduled task which is running every day at night. This script could be populating the computer accounts for all user account in the organization or in a particular OU.

You could try moving user accounts to a different OU to see if it is affecting users in an OU. But this would require all user settings be moved to the new OU, like the GPOs.

Also, you could search for Scheduled Tasks configured on Domain Controllers or Management Workstations.

Another option would be to enable Auditing for the AD Accounts in order to find which account is making modifications to user accounts.
0
McKnifeCommented:
yes, correct, audit account management to see what process that is. It will be a scheduled task for sure, so you could also list all tasks on the DCs and see which of those run after hours and find it.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Thomas NZSystems EngineerAuthor Commented:
@ Sekar Chinnakannu   i have tried this but was a 50/50 shot.

Seems its something changing AD.  What the best proccess to audit account management to see what process that is?
Currently have 3 domain controllers one which is old 2008 standard and two new 2012 R2. Below are all the schedule task setup.

2008 DC
new.PNGnew2.PNGnew3.PNG
No tasks have been created on the new domain controllers.
I did notice that it must change between 3am-7am
0
SreRajCommented:
To audit Account Management, you should first enable the audit setting in Default Domain Controller Policy.

This can be done from a Domain Controller with the help of Group Policy Management Console.
Open GPMC from Administrative Tools -> Group Policy Management
Then Go To Domain Root -> Domain Controllers OU -> Default Domain Controller Policy.

Right click on the Default Domain Controller Policy and select Edit

In the GP Editor, go to Computer Configuration -> Policies -> Windows Settings -> Security Settings -> Local Policies -> Audit Policy

Select Audit Account Management and enable Policy Setting for Success.

Once the Audit Policy is configured, account management events will be logged in Security Log of Domain Controllers. You could check for Event ID 4738, which is the event for successful user modification. You may have to increase the size of Security Log file as it may get overwritten over a period of time.

If you want to find the Domain Controller and exact date and time when a particular user object was changed, you could use the following command.

repadmin /showobjmeta <Name of a DC> <Distinguished Name of User Object>

Example:
repadmin /showobjmeta DomainController1 "CN=User1,OU=Users,DC=Test,DC=com"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thomas NZSystems EngineerAuthor Commented:
Thanks will get this setup and come back to you.
0
Thomas NZSystems EngineerAuthor Commented:
checked logs this morning and found
experts.jpg
this was logged before the second picture
 

Then this is one of the user accounts that change everyday
new4.PNG

From what i see it s must be something on the domain controller because of the Account Name its using.
0
Thomas NZSystems EngineerAuthor Commented:
Found the problem here!!! :)   Thanks for everyones input!

After finding that event which pointed to something running on the server itself as SYSTEM. Noticed it said Windows Server standard but was Windows 2008 Essentials Business Server!

This has the Windows Essentials Business Server Administration Console. Now it was only licensed for some users and some devices etc... This only allowing login to licensed computers etc......
So real fix is to decommission the DC and use the two 2012 R2 domain controllers.

Thanks again!

found.JPG
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.