Import-CMDriver fails with "Import-CMDriver : Invalid object path "

Posted on 2014-08-06
Last Modified: 2015-01-30
I am attempting to use Import-CMDriver cmdlet for SCCM 2012 R2 but it fails with:

"Import-CMDriver : Invalid object path "

I can see that it is adding the driver to the catalog, but it is failing to add it to the package and I can't figure out why.  I have tried with different inf files and deleted and created different packages.  It just doesn't work.  Here is the command that I am running.  I don't see any reason why it wouldn't work.

 Set-Location abc:
    foreach($iniFile in $infFilesToDeploy){
        $cmDrivePackage = Get-CMDriverPackage -Name "PackageName"
        $cmDriverCat = Get-CMCategory -CategoryType "DriverCategories" -Name "PackageName"
        Import-CMDriver -UncFileLocation $iniFile -ImportDuplicateDriverOption AppendCategory -AdministrativeCategory $cmDriverCat -EnableAndAllowInstall $True -DriverPackage $cmDrivePackage -UpdateDistributionPointsforDriverPackage $false
As I said, it is seeing the ini file since it it importing it into the catalog.  It just won't add it to the package.  It also leaves the package in a locked state if I try to modify it after I run this command.

Anyone have any ideas why this command doesn't function?

I even tested without adding to a package:

Import-CMDriver -UncFileLocation "\\abe\drivers$\test\Display.Driver\nv_disp.inf"

I get the same error message about invalid object path.  It still adds the driver to the driver catalog, but displays this error message.  Seems like a bug here.  Anyone else able to add drivers using this cmdlet?

I am running this on Windows 8.1.  I also tried it on the SCCM server running Server 2012 and I get the same error.

Thank you for your time.
Question by:gacus
    LVL 1

    Author Comment

    If I enable -verbose, I can see this WQL query is failing:

    VERBOSE: Executing WQL query: Select CTC.CI_ID,CTC.ContentID From SMS_CIToContent As CTC Join SMS_Driver As DR On

    Seems to be a bug....
    LVL 1

    Author Comment

    SCCM version 5.0.7958.1303
    LVL 1

    Accepted Solution

    This was a confirmed bug my MS.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Join & Write a Comment

    This collection of functions covers all the normal rounding methods of just about any numeric value.
    This script checks a path to see if a folder exists. If the folder does exist you will get output "The folder has previously been created. No action taken" If not it will create the folder. Then adds one user modify permission to the folder. It …
    Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
    The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now