• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 844
  • Last Modified:

Configure voice vlan on a Cisco 2960.

Hello Experts,  

I didn't work on Cisco for a while but my new customer is cisco.  Simple network, ASA5505 and a cisco 2960. he was working with unmanaged switch before but he move over VoIP so we purchased that manage switch.

I create a vlan 30 and 40 on the switch. ( you can have a complete config on the file join to this tread.. )  30 should be Network Data and 40 is VoIP. i don't use the
default at the moment.

My issue sounds simple, my voice vlan can't get an ip from the dhcp server.
My dhcp server is set as interface GigabitEthernet1/0/1, switchport access vlan 30,  switchport trunk native vlan 30, switchport mode trunk

To test my dhcp i have configure a port set as interface GigabitEthernet1/0/37, switchport access vlan 40, switchport mode access, switchport voice vlan 40
 spanning-tree portfast without success...

Long time ago i was working on with cisco 3750, those are layer 3 and my default gateway was the vlan IP, this time, my default gateway is the ASA, is it ok ?

 No sure if i'm using the right version of System images "flash:/c2960s-universalk9-mz.122-55.SE7/c2960s-universalk9-mz.122-55.SE7.bin" ?

May be the vlan ip helper should be set on the ASA ?  by the way ASA is able to ping both vlan Ip interface..  

Any help appreciated..  The phone system should be installe next monday.

thanks,
sh-version.txt
Sh-run-conf.txt
0
Ti360
Asked:
Ti360
  • 3
1 Solution
 
kevinhsiehCommented:
From what you have described there is no way for the DHCP requests to get to a DHCP server. You need to either configure the DHCP server on the ASA or setup DHCP relay on the ASA.

Your switch knows nothing about IP traffic and isn't involved in the DHCP configuration. The switch just needs to make sure that VLAN 40 is assigned to your phones and that VLAN 40 can talk to the ASA via a trunk interface.

http://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116265-configure-product-00.html
0
 
eeRootCommented:
Depending on what type of phone you have, you may need to either set the VLAN on the phone, or set a DHCP scope option to point to the correct VLAN and?or VoIP server.  Will one of your phones work, if you manually set the VLAN and IP info on it?  What type of phone system and phones do you have?
0
 
Ti360Author Commented:
We purchased a Mitel phone system, i do not have the phone model at the moment only a demo.  i saw on another 2960 inter vlan routing or basic routing function. i do not know how to enable that feature on the switch but that my solve my issue..
intervlan.PNG
0
 
Ti360Author Commented:
I figure it out,  after upgrading my firmware to the latest stable version, i enable routing using that command :
sdm prefer lanbase-routing than run IP routing

I start from that URL to understand it..
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_55_se/configuration/guide/scg_2960/swipstatrout.html#wp1202471

The 2960 has very limited vlan routing function.

Thanks,
0
 
Ti360Author Commented:
Get it working from Cisco comunity blog
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now