Exchange 2010 Out Of Office not working for one user

I have one user whose out of office is not working. He has set it up in Outlook with no issues.

What I have tried so far

1. Setting up the OOF in OWA as well
2. Setting up OOF with and without date ranges
3. Moved the users mailbox to different mailbox database
4. I ran the [Exchange Web Services synchronization, notification, availability, and Automatic Replies.] test on www.testexchangeconnectivity.com and it was successful

What further things can I do to troubleshoot this please.
LVL 1
takwirirarIT Projects ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhandelsCommented:
Hey,

I have often seen this happening when the user has created client side rules for his mail archiving. You can try and startup Outlook with the following command line. Outlook.exe /cleanclientrules.

Do keep in mind that all client rules will be removed from the Outlook client.
If that doens't work you could try to create a new Outlook profile (and just keep the old one for fallback), it might just work.
0
imkotteesSenior Messaging EngineerCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
takwirirarIT Projects ManagerAuthor Commented:
I have tried cleaning the rules and thats not worked.
imkottees I have gone through the instructions on the site as well but PR_OOF_STATE says False although Outlook says my OOF is on. I have run Get-MailboxAutoReplyConfiguration –identity <<user>> and it says AutoReply state is enabled.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

rhandelsCommented:
Did you try creating a new profile?
And about stating the obvious. When OoF is enables it will only send an e-mail the first time a user sends an e-mail, when testing, did this user already send an e-mail when you tried? Also, are u using an internal mail address? Or External? Because you need to configure OoF separately for both.
0
takwirirarIT Projects ManagerAuthor Commented:
Yes I created a new profile. I've tried internal and external addresses. I have a Hotmail, Gmail, Yahoo etc. that I've been trying separately. OOF is configured for both internal and external.
0
Murali ReddyExchange ExpertCommented:
Are you getting an error while applying the OOF? Did you tried applying from the Exchange using Set-MailboxAutoReplyConfiguration?

Run 'Get-MailboxAutoReplyConfiguration -Identity <MailboxName>' to check if the OOF is set up correctly.

If this was the issue for all the mailboxes, check your EWS virtual directory authentication settings for anonymous user, should be enabled.
0
rhandelsCommented:
Pfff, okay then.

You might wanna try with /cleanrules option, this deletes the local and server rules, because you said that even setting it in OWA didn't work.
0
takwirirarIT Projects ManagerAuthor Commented:
No errors when I apply OOF.
Get-MailboxAutoReplyConfiguration is showing everything setup correctly unless there are things I need to look out for.
Correct this is just one mailbox affected.
I tried the /cleanrules but thats not made a change.
0
rhandelsCommented:
I new we had the same issue once. What we eventually did is use the MFCMapi tool to check and see what rules were applied and deleted the corrupted ones. If the user doesn't have any rules, you might be able to delete them all and reconfigure the OoF rule.

http://support.microsoft.com/kb/924297

If this doesn't work i'm really out of ideas..
0
takwirirarIT Projects ManagerAuthor Commented:
I got to step 5g. but could not see any hidden messages with the IPM.Rule.Message class. Probably because I ran /cleanrules etc earlier on
0
rhandelsCommented:
What happens if you disable the OoF now then, close Outlook and start it up again? It seems as if the rule has been deleted..
0
takwirirarIT Projects ManagerAuthor Commented:
I removed OOF, closed Outlook. Opened it again and created the OOF message. When I log into the MFCMapi this is what I have.

Current Table
0
rhandelsCommented:
I'm sorry but i'm out of ideas here.. It seems as if the rules of this person are corrupted but with no way of deleting it..
0
takwirirarIT Projects ManagerAuthor Commented:
Hi, the issue self resolved! After a while it just started working again. I noticed that all the people that had left the company and I had disabled their accounts were having the same issue. Moving them back to the live accounts and back again seemed to resolve it.
0
Senior IT System EngineerIT ProfessionalCommented:
ok, does the OOF email is sent out once per 24 hours for every sender that sends email to the mailbox ?
0
takwirirarIT Projects ManagerAuthor Commented:
Please rephrase your question. I don't understand exactly what you mean
0
Senior IT System EngineerIT ProfessionalCommented:
ok, how does OOF email is sent to the sender both externally and internally ?
how often daily do they get sent when activated ?

does it sent out once to the sender or multiple times every email sent to the mailbox ?
0
takwirirarIT Projects ManagerAuthor Commented:
Yes its working both externally and internally.

It sends once.
0
Senior IT System EngineerIT ProfessionalCommented:
Cool, so on this case is it possible to control how often the OOF email sent rate ?

Or this is the default value that cannot be changed ?
0
takwirirarIT Projects ManagerAuthor Commented:
I think that is the default operation. I don't think you can change that. I suppose you could use some Transport Rules or other rules within Outlook to achieve what you want. My suggestion is you open a new case for that.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.