Cannot send to some btconnect email addresses from Exchange

I have a SBS2008 server running Exchange 2007 over a BT Broadband connection. Email works fine with the exception that delivery of some btconnect address are delayed and may not arrive at all. Sometimes they are delivered but after an extended period.
I have worked through Alan Hardisty's document (http://www.experts-exchange.com/Software/Server_Software/Email_Servers/A_2427-Problems-sending-mail-to-one-or-more-external-domains.html) which has always served me well but on this occasion, although everything seems to check out OK, I still have the problem. No doubt it's something I've missed but it escapes me as to what it is.
ClintonKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Are you using BT's smart host for delivery, or going direct?
If you are on a BT connection yourself, then you could consider using BT's smart host for their own domains and route everything else directly.

Although BT are in the middle of changing their web host, so this could be a side effect of that.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ClintonKAuthor Commented:
OK, Sounds like a plan. I'm not familiar with smarthost config but have just done some reading and I think I get the gist of it. Do you know where I can get the BT Smarthost details please?
0
Simon Butler (Sembee)ConsultantCommented:
Just look on BT's web site for the outbound SMTP server for their POP3/IMAP accounts. It will probably be something like mail.btconnect.com .

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ClintonKAuthor Commented:
Finally got the login details. I'm now trying to configure a new send connector using the SMTP details from the BT website, i.e. mail.btinternet.com and using the associated login details as if I was configuring the email account from within Outlook. Two question:
1. The BT web page specifies SSL and port numbers. How can I enter these into the send connector?
2. How can I tell if the email addresses, <anyone>@btconnect.com are trying to use the new connector?
0
Simon Butler (Sembee)ConsultantCommented:
From memory, I don't think BT use anything different to regular ports.

However if you want to specifically enter a port you need to create the Connector using the wizard, then modify it within EMS:

Set-SendConnector "BT Connector" -port 1234

Change "BT Connector" to the actual name of your connector and 1234 to the port you want to use.

To use TLS:

set-sendconnector "BT Connector" RequireTLS:$True

To confirm if it is being used, message tracking should tell you.

Simon.
0
ClintonKAuthor Commented:
I've verified the BT mail servers. Seems the SMTP server is now smtp.office365.com so I've tested this in Outlook with my username and password and I can send email.
I've configured the same parameters in a new Send Connector in Exchange 2007 and configured it with an address space of SMTP *
I have disabled the default connector so only my new one is active. When I try to send emails I now get a delivery failure with this message:
<recipient.name>@<theirdomain.com>
CO2PR04CA037.outlook.office365.com #550 5.7.1 Client does not have permissions to send as this sender ##
0
Simon Butler (Sembee)ConsultantCommented:
With BT you usually have to tell them what domain you are sending from which they add to the list that can use their servers.
 
As such, if you are attempting to relay all email through their servers it may well fail. What you want to do is just relay email for btconnect.com addresses, then you could set the Smart host to use their MX record address instead. However it would only accept email for that domain.

Simon.
0
ClintonKAuthor Commented:
In my attempt to configure a smarthost last night, I disabled the default send connector and enabled my new send connector as I said in my earlier post. However, all this is because I can't send to btconnect addresses. While my new send connector was enabled, the btconnect email I have waiting to be sent also complained about client permissions, which I expect is normal, but does that indicate that the email has not even left the Exchange server? The original message I get before dabbling with Smarthosts is "This message has not yet been delivered. Microsoft Exchange will continue to try delivering the message on your behalf"
Am I still barking up the correct tree?
0
Simon Butler (Sembee)ConsultantCommented:
BT Connect isn't a service run by BT, they have outsourced it Office365 it would seem. BT have been shutting down their email services for a while now, the consumers got stuck with Yahoo at one point.

As such, being a customer of BT means nothing, because the traffic is actually going to Microsoft's platform. BT can make some minor changes, but as far as I am aware this is just the same as any other customer of Office365.

The error may well be a routing issue. Have you confirmed that you are able to connect to the MX record host?

There was no need to disable the Default Send Connector, as Exchange uses the closest match. Therefore you could just add the domain to a new connector and it would be used by Exchange.

Simon.
0
ClintonKAuthor Commented:
How can I confirm that I can connect to the MX record host?
Not wishing to complicate this and divert from the original question but I think it's relevant to also mention that I look after another SBS server (a SB2011 running Exchange 2010) and that has problems sending to AOL addresses - comes back with the same message about delivery delayed. The SBS2011 site has just moved to BT and now cannot sent to AOL. The SBS2008 site I referred to in my original question can send to the AOL addresses but not BTconnect. Before the SBS2008 site was upgraded from SBS2003 they were using the same BT provider and were able to send to BTConnect.
I'm sure there must be some commonality here but I can't spot it.
0
ClintonKAuthor Commented:
I have now configured a Smarthost.
I had to phone BT support and ask them to configure my domain name to the account (the domain name is not registered with BT). Once this was done, they gave me the SMTP server name which is mail.btinternet.com and uses port 25. For smarthost, I set the authentication to "None" and mail successfully sent via my new send connector. I did this using a test email recipient. The real test will be when an email is sent to a btconnect address tomorrow when the office opens.
I'll update tomorrow with the result.
0
ClintonKAuthor Commented:
All seems good now, with one exception which was a single email to a little known .com address which was delayed but apart from that all mail seems to be flowing well.
Thanks very much for the solution. I'm now going to apply the same one to my other client who has trouble sending to AOL
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.