Problem to see Chinese

Hi,
what is the proper way to enable Unicode code like Chinese on the browser, called Epiphany?

I do run this

huamin@:~ % setenv PACKAGEROOT ftp://ftp.freebsdchina.org
huamin@:~ % 

Open in new window


but after that, I still cannot see Chinese on browser.
LVL 11
HuaMin ChenProblem resolverAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HuaMin ChenProblem resolverAuthor Commented:
Any help?
0
serialbandCommented:
According to the gnome epiphany page you just need to set the language preferences.  https://help.gnome.org/users/epiphany/2.91/ephy-customize.html.en#language-preferences

You may also need to install fonts, according to a Debian Forum.  http://forums.debian.net/viewtopic.php?p=361217
apt-get install ttf-arphic-gbsn00lp ttf-arphic-gkai00mp
aptitude install ttf-sazanami-gothic ttf-sazanami-mincho ttf-wqy-microhei
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, I see within the browser, it is having

View > Text encoding > Unicode
t802.png
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

serialbandCommented:
What happens when you select other?  Have you tried installing additional fonts?
0
HuaMin ChenProblem resolverAuthor Commented:
which others to select? Can I have the details to install additional fonts?
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Hi, just so I understand the issue, I installed Epiphany in a (Ubuntu) virtual machine and set Text Encoding to Chinese Traditional and then opened a Chinese website. It looks OK to me, is this what you require? See attached image.Epiphany in Chinese
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, I have the problem to view Chinese with Epiphany in FreeBSD.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Ok, which version of FreeBSD is that?
0
HuaMin ChenProblem resolverAuthor Commented:
Thanks. It is FreeBSD 10.0
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Forgot to ask but which GUI? KDE Gnome or other? Which did you install?
0
HuaMin ChenProblem resolverAuthor Commented:
I set up Free BSD 10.0 and Epiphany is the browser within that. Thanks
0
Gerwin Jansen, EE MVETopic Advisor Commented:
I've installed FreeBSD 10.0 before, it comes without GUI, you have to install it yourself. If you did not install it yourself, where did you download FreeBSD then?
0
HuaMin ChenProblem resolverAuthor Commented:
From Free BSD site.
0
HuaMin ChenProblem resolverAuthor Commented:
I have set up GUI of that. If not, I could not use Epiphany.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Which GUI?  KDE or Gnome? Probably Gnome? See my question above where I ask the same.
0
HuaMin ChenProblem resolverAuthor Commented:
Gnome.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Yes, thought so, I'm having trouble as well getting chinese displayed properly in Ephiphany.

Are other browsers an option for you? Or is Ephiphany required?
0
HuaMin ChenProblem resolverAuthor Commented:
I have set up Firefox 33 within FreeBSD but after that, I cannot find out Firefox to use.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Did you reboot? If not, from a terminal window: /usr/bin/firefox

I tried Opera - no Chinese characters as well :(
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, I get the attached.
t851.png
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Firefox is not installed properly. That with the other browsers I tested (all not working) I suggest you change to Ubuntu (virtual possibly), I don't see options to get this working in FreeBSD
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, the point is, there should be some other way to see Chinese in FreeBSD.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Then you may Request Attention for this question - I have spent some time on your question and could not find a solution. What makes you think there "must be" a solution? It could very well be that there is none.
0
serialbandCommented:
@Gerwin
I would think there would be a solution, since BSD is a branch of linux, and you could probably install the X fonts in place just as you could with other linux.  OSX, another BSD, has Chinese fonts as a multitude of others.  It has gnu tools just as other linux has, so someone worked on them and they exist.

I left the question after my first response because you came in with a screen shot of epiphany on ubuntu with Chinese fonts, so I thought you new the exact answer.  My initial suggestion about installing fonts might still work.  I don't happen to know what's available since I've never used FreeBSD, but the problem seems to possibly be missing fonts.

@HuaMinChen  As I don't know the inner workings of FreeBSD, I wouldn't be able to help with that.  Please request attention.  On Ubuntu and other Debian based systems, you'd just apt-get them.  On Redhat variants you'd just yum Install them.  <-- maybe this will lead you to the right path.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
@serialband - good suggestion, I'll have a go at adding X fonts, will let you know.

<edit>

Went ahead and installed some additional fonts - crashed my VM yet again. I'm done for now. If you have an easy way of adding chinese X  fonts, I may reconsider.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HuaMin ChenProblem resolverAuthor Commented:
Thanks all.
Is there any other ways to this?
0
Gerwin Jansen, EE MVETopic Advisor Commented:
At the moment I don't have new insights. My advice would be another Linux distribution as I said before.
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry for that I expect to have the solution on FreeBSD.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.