Baffled by Internet Speed Issue

Hi folks,

I am absolutely stumped.

We have cable Internet service shared throughout our home by a Netgear 150 Mbps wireless N router. All but one of our computers typically perform well, and tests run at speedtest.net consistently show speeds of around 10-11 Mbps.

We have one desktop computer, however, that routinely tests at less than 1 Mbps -- often down around 0.5 Mbps! -- and always handles the Internet at a snail's pace. I have done everything I can think of. I've replaced both the wireless adapter on the PC and our wireless router with new units in case they were malfunctioning. I've wiped the PC and re-loaded Windows 7 (Pro x64) from scratch. Nothing changes.

I've brought other computers into the same area of the house to make sure something wasn't killing the wireless signal. Nope, they do fine.

Any idea what could possibly be causing this?

Thanks,
Ithizar
IthizarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
Ithizar --
Run the speedtest on the slow PC plugged into  the cable directly without the router in the middle.  Does that improve the speed?

How old is the PC?  What  browser?  Is this the same for all PC's?
0
IthizarAuthor Commented:
Hi, and thanks for your comment!

As I detailed in my original post, the other PC's in the house are working fine.

Logistically, it would be a bit difficult for me to get the PC into proximity with the router and plug it in directly. I can do that if absolutely necessary. However, since all of the other PC's in the house perform flawlessly, it strikes me that it is unlikely the router is at fault. Though I wouldn't rule anything out.

The PC is about 2 years old, but it was custom built as a high-end machine (AMD FX 8350 quad core processor, 16 GB DDR3 RAM, etc.), so it still has very respectable specs. The normal browser in use is Firefox, but switching to a different browser makes no difference in the test results.

Thanks,
Ithizar
0
JohnBusiness Consultant (Owner)Commented:
If you can get the machine to the modem, then I suggest you try. Like jcimarron, I test computers at the cable modem to determine if there is a fault in the computer.

I know you have reloaded Windows on the problem computer, but try running TCP/IP Reset.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Restart the computer

Make sure there are no IP conflicts in your gear. All should be DHCP and none static.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

selvolCommented:
Possibe a TCP/IP Tweek.


http://www.speedguide.net/downloads.php

Selvol
0
JohnBusiness Consultant (Owner)Commented:
I used to use Tweakmaster in XP days and found that tweaks did not do anything much. Newer systems have better TCP/IP implementations.

If you do make changes, document them specifically so you can undo them. TCP/IP Reset will remove any tweaks.
0
Scott ThomsonCommented:
I would test with the following
1. Test how fast you can send a receive a file between this machine and another - this will determine if for some reason there is a difference between http traffic and regular data traffic on your network
IE - if you are getting slow transfer rates sending data internally on your network then it means the issue is not your internet at all. its just the network device or your configuration.

2. How far away is this machine and what sort of objects are between this machine and the router in question?

3. What router are you using and what wireless card are you using.? the difference may (not always) but may be the cause. You also stated your router is 150 but didn't state what connection your wireless card was. this is a good reason to tell us the card or to check on the cable as requested earlier. Even if you only move the machine itself and not the monitor and dial into it remotely.. you can still then test..

4. Where do you live? in an apartment or a house? are there many other wireless connections around you?
0
IthizarAuthor Commented:
The solutions selected did not totally fix the issue -- I am still seeing lower speeds than on other wireless devices -- but did make a significant improvement and at least make the PC usable. Thanks to everyone who replied!
0
JohnBusiness Consultant (Owner)Commented:
@Ithizar  - Thank you for the update and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.