During a client installation-My new SQL server 2012 is not listed , when i choose the drop down menu .

Hi

We had a old access control server, and the access control  application was installed on SQL 2005( windows 2003 Server).
Now I have built a new SQL server 2012 (Windows 2012) and we have migrated the database form old server to our new SQL 2012 server.

We have a client application which needs to be installed on the client PC  and this will be the console to the access the new Access control server.

During the client installation (access control console) on a  windows 7 PC, It defaults to C:\program files
On the next screen I get a "Define connection string" dialog box.
In this screen it says this screen will help you to define a database connection information.
I click the "define connection string"
I get a  connection properties windows see the attached.

On the Server name if I drop down to select the new access control server, the new server is not listed. But I can see our old access control server and few other servers which is on our network. Do I need to give additional permissions on the new server- SQL database  to list my new server here.

On this tab I will be using the  SQL server authentication  and select the database name.

Please suggest as how I will be able to list my new server , when I click the drop down menu. Any help to sort this much appreciated.

Thanks
connection-string-window.docx
lianne143Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Anthony PerkinsCommented:
If this is a SQL Server Express, then you are probably using a named instance in which case you need to make sure the SQL Browser is running.
0
nemws1Database AdministratorCommented:
The dropdown will only work in certain cases.  You need to make sure your server allows connections to UDP port 1434 (enable in Windows Firewall) and that you're running the SQL Browser process (you can check this by running the "SQL Server Configuration Manager".
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Would help if you post here a screenshot of the connection window.
Maybe you just need to write the new servername if the combox box is editable,

Cheers
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

lianne143Author Commented:
It is installed on SQL 2012 with default instance and mixed mode.
I checked and the SQL browser service is running.

I created an inbound rule on the SQL server firewall and allowed connections on port 1433 UDP.
I am able to write the new server name on the server name tab.
This is a dedicated server for access control and if I drop downs the arrow under connect to Database , it is not listing any database , but I am able to write the database name here.
The access control vendors have installed the access control application on the SQL server.
If I know the database name I will be able to write here, Not sure which would be the database name.
Under  Microsoft SQL management studio under If I expand the Databases , I can see  "Control"  will this be a database name (This name corresponds to the software vendor)

Please suggest the best way of sorting this.

Thanks in advance.
Snapshot-Connection-win-and-Database.doc
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Can't you change the data source to SQL Server Native Client instead of .NET Framework Data Provider for SQL Server?

For you use the Windows Authentication mode you need to create the correct login in SQL Server instance. Why are you using SA credentials?

And port 1433 should be TCP. 1434 it's the UDP.
0
lianne143Author Commented:
It doesn't allow me to change data source to SQL Server Native Client instead of .NET Framework Data Provider for SQL Server.
The change option is completely greyed.

Sorry I had specified the UDP to 1434 ( Typing error)
I am not sure the software vendor was using the SA credentials  and I will ask then why they are using the SA.
Do I need to open inbound TCP as well
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
You shouldn't open nothing if there's no firewall between those two machines. Otherwise you will need to open it also.
What happens when you click on "Test connection" button?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nemws1Database AdministratorCommented:
Wouldn't hurt to open up TCP port 1433 as well.  Just to recap, you *ARE* now seeing the server, but you are unable to properly connect to it (thus, you don't get a database list).

Are you seeing any failed login errors in the SQL Server log?
0
lianne143Author Commented:
Thanks you so much guys for your posts. I opened 1433 on the server(inbound) When I click "Test connection" button? It says server OK and it works.
Also lists the databases.
0
nemws1Database AdministratorCommented:
Good to hear you got it working! :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.