• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1265
  • Last Modified:

How do I start Exchange Transport Service in Exchange 2010

Hi

I have Windows Server 2008 R2 hosting Exchange Server 2010.
After a prolonged blackout, my ups gave away before I could gracefully shutdown the exchange server. After replacing the UPS and booting the server, I found out that Exchange Transport Service didn't start. I did a manual start of the service but failed with error. The Event ID of the error in event viewer is 17003 (attached). I did some search which said about repairing the pasettings.edb file. The funny thing is that i can not find that file and even the SenderReputation folder (C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data\SenderReputation\ pasettings.edb). I have a default exchange installation.
Attached is the error message of Event ID: 17003. Any help is NEEDED. Thank you.
Log Name:      Application
Source:        MSExchangeTransport
Date:          11/08/2014 2:56:44 PM
Event ID:      17003
Task Category: Storage
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxx.xxxxxx.local
Description:
Transport Mail Database: An operation has encountered a fatal error. The database may be corrupted. The Microsoft Exchange Transport service is shutting down. Manual database recovery or repair may be required. Exception details: Microsoft.Exchange.Isam.IsamLogFileCorruptException: Log file is corrupt (-501)
   at Microsoft.Exchange.Isam.JetInterop.MJetInit(MJET_INSTANCE instance)
   at Microsoft.Exchange.Isam.Interop.MJetInit(MJET_INSTANCE instance)
   at Microsoft.Exchange.Transport.Storage.DataSource.InitInstance()
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchangeTransport" />
    <EventID Qualifiers="49156">17003</EventID>
    <Level>2</Level>
    <Task>17</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-08-11T04:56:44.000000000Z" />
    <EventRecordID>340385</EventRecordID>
    <Channel>Application</Channel>
    <Computer>xxxxxxxx.xxxxxxxx.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Transport Mail Database</Data>
    <Data>Microsoft.Exchange.Isam.IsamLogFileCorruptException: Log file is corrupt (-501)
   at Microsoft.Exchange.Isam.JetInterop.MJetInit(MJET_INSTANCE instance)
   at Microsoft.Exchange.Isam.Interop.MJetInit(MJET_INSTANCE instance)
   at Microsoft.Exchange.Transport.Storage.DataSource.InitInstance()</Data>
  </EventData>
</Event>
==========================================
**Author Accepted Solution, Original Points: 500**
0
Teine KOROKOI
Asked:
Teine KOROKOI
  • 2
1 Solution
 
Miguel Angel Perez MuñozCommented:
Have you got any kind of backup?

Probably this database is corrupted or erased, you can try recover from backup or repair (but you said database file not exist).
At this point, you can try recover from backup or do a exchange recovery: http://technet.microsoft.com/en-us/library/dd876880(v=exchg.141).aspx
0
 
Simon Butler (Sembee)ConsultantCommented:
Do you have anything in
"C:\Program Files\Microsoft\Exchange Server\TransportRoles\data\SenderReputation"

If you do, delete the entire contents of the directory. Then attempt to restart the transport service.

Simon.
0
 
Teine KOROKOIAuthor Commented:
Than you simon and Miguel for your comments.
1. I don't have a SenderReputation folder in C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data. Am I missing something?
2. I have deleted the files in queue folder in C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data and was able to start the transport service
3. Upon trying to mount the database, I am getting this error (posted below). I have run eseutil to bring the .edb file form dirty shutdown to clean shutdown (repair) but still unable to mount the db.

Could someone please highlight the steps I could take to restore my exchange?

I would like to exhaust the options i have before trying what Miguel suggested above.

Thank you.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Mailbox Database 0663128630'.

Mailbox Database 0663128630
Failed
Error:
Couldn't mount the database that you specified. Specified database: Mailbox Database 0663128630; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorInvalidSesid: Unable to mount database. (hr=0x80004005, ec=-1104)
 [Database: Mailbox Database 0663128630, Server: BackupDC.cimcina.local].

An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorInvalidSesid: Unable to mount database. (hr=0x80004005, ec=-1104)
 [Database: Mailbox Database 0663128630, Server: BackupDC.cimcina.local]

An Active Manager operation failed. Error: Operation failed with message: MapiExceptionJetErrorInvalidSesid: Unable to mount database. (hr=0x80004005, ec=-1104)
 [Server: BackupDC.cimcina.local]

MapiExceptionJetErrorInvalidSesid: Unable to mount database. (hr=0x80004005, ec=-1104)





--------------------------------------------------------
OK
--------------------------------------------------------
0
 
Teine KOROKOIAuthor Commented:
Hi all

I have managed to mount my database and exchange is up.

I moved the exchange log files to a new location and mounted the database and its working now. However I still don't understand why I don't have the SenderReputation folder in C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data

Thank you

Teine
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now