[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2110
  • Last Modified:

Can't make Hyper-V VM highly available - Server 2012 R2 cluster

I have created a Server 2012 R2 cluster  and am trying to make a VM highly available but i get a message stating

"There was a failure configuring the virtual machine role for 'Win7-Test'.
There was an error retrieving the unique identifier for the Cluster Shared Volume that contains the path 'F:\Win7-Test'.

The parameter is incorrect"

The VM is on DAS with is added to the cluster.  Not sure why this isn't work.
0
DTUser
Asked:
DTUser
  • 5
  • 5
  • 3
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Does your Cluster work?

When you ran the Failover Cluster Wizard, and add both nodes, did it pass ?
0
 
Cliff GaliherCommented:
Under normal circumstances. You can't use DAS for cluster storage. And further, a CSV would almost never be on a root drive letter such as F:. So it looks like you've configured your storage and your CSV incorrectly.
0
 
DTUserAuthor Commented:
The cluster works and passed all validations.  When I said DAS, I meant a disk array (Dell MD3200) connected with SAS cables.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you created a CSV ?
0
 
Cliff GaliherCommented:
We are still back to the error mentioning an F: drive. When you create a cluster shared volume, it adds the storage as a prepares point under c:\clusteredstorage so the error indicates that the CSV was not properly created. I'd look at your forage setup under the failover cluster manager.
0
 
DTUserAuthor Commented:
I do have the junction points in C:\ClusteredStorage and they are working to redirect to the F and G drives.  Is there a way I can verify this is working in the cluster manager?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Is your VM in Cluster Storage, and does it appear in the Cluster Manager - the VM ?
0
 
DTUserAuthor Commented:
it does not.  That's where I'm getting the error.  I"m trying to add the Cluster role --> Virtual machine, and when it tries to complete it errors out.  The VM itself is on the drive that's part of the cluster though.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you follow this...

http://technet.microsoft.com/en-us/library/dd759216.aspx

and create the VM in the CSV ?
0
 
DTUserAuthor Commented:
I don't think this applies.  My servers are running 2012 R2, this article is for 2008 R2.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Does not seem to have changed much to me...

http://technet.microsoft.com/en-gb/library/jj863389.aspx#BKMK_step7

Did you create the VM in the CSV ?
0
 
Cliff GaliherCommented:
When you created the CSV, it takes complete control of the storage. The F: and G: drive letters should no longer be mapped to the disks at all. Doing so, in fact, breaks how the CSV redirector works for metadata writes work and data corruption can occur.

When adding the VM to the cluster manager, you *must* reference the VM (and the VHD/X storage files) through the C:\ path. If the VM or the VHD files (in Hyper-V manager) still reference the other drive letters at all, you will get failures adding it to the cluster manager. And, as mentioned, the drive letters should not exist anyways, so this should be a non-issue.

The handling of CSVs was changed in 2012 to support the SOFS architecture, so what you may have done in the 2008 series era of servers no longer necessarily will work with the 2012 era.

-Cliff
0
 
DTUserAuthor Commented:
Thanks, this has helped.  The storage was available with both the C:\ path AND an F: path.  I removed the F: designation and now VMs located on that drive are importing correctly into the cluster.
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

  • 5
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now