FSRM sends test email but no email when over quota

Hiya,

In FSRM on a Windows 2008 R2 Server I have configured a quota template for a file share and applied it to a quota to alert at 70% and 90%

The test email goes fine to the Admin email address within Configure Options but when the quota is exceeded, FSRM cannot send email to users.  I get this error. I've attached 2 screenprints but can't see what the problem might be

Log Name:      Application
Source:        SRMSVC
Date:          01/08/2014 16:08:03
Event ID:      12306
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      XXXXXXXXXXXX
Description:
A File Server Resource Manager Service email action could not be run.

Operation:
   Running email action.
   Quota threshold reached.
   Processing File Server Resource Manager event

Context:
   Action type: Email Action
   Mail-from address: XXXXXX@aviva.com
   Mail-reply-to address: XXXXXX@aviva.com
   Mail-to address: XXXXXX@aviva.com;
   Mail-CC address:
   Mail-BCC address:
   Mail subject: 70% quota threshold exceeded
   Mail message text: The 70% quota threshold for quota on D:\ModelStore on server XXXXXXXX has been exceeded. The quota limit is 3891200.00 MB and the current usage is 2724669.26 MB (70% of limit).
   Quota path: D:\ModelStore
   Threshold percent: 70

Error-specific details:
   Error: IFsrmEmailExternal::SendMail, 0x8004531c, The parameter 'addresses' cannot be an empty string.
Parameter name: addresses
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SRMSVC" />
    <EventID Qualifiers="32772">12306</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-08-01T15:08:03.000000000Z" />
    <EventRecordID>12321</EventRecordID>
    <Channel>Application</Channel>
    <Computer>XXXXXXXXXXXX</Computer>
    <Security />
  </System>
  <EventData>
    <Data>

Operation:
   Running email action.
   Quota threshold reached.
   Processing File Server Resource Manager event

Context:
   Action type: Email Action
   Mail-from address: xxx@aviva.com
   Mail-reply-to address: xxx@aviva.com
   Mail-to address: xxx@aviva.com;
   Mail-CC address:
   Mail-BCC address:
   Mail subject: 70% quota threshold exceeded
   Mail message text: The 70% quota threshold for quota on D:\ModelStore on server XXXXXX has been exceeded. The quota limit is 3891200.00 MB and the current usage is 2724669.26 MB (70% of limit).
   Quota path: D:\ModelStore
   Threshold percent: 70

Error-specific details:
   Error: IFsrmEmailExternal::SendMail, 0x8004531c, The parameter 'addresses' cannot be an empty string.
Parameter name: addresses</Data>
    <Binary>2D20436F64653A20454D4C4E54524C4330303030303139322D2043616C6C3A20454D4C4E54524C4330303030303038332D205049443A202030303030313931362D205449443A202030303030333634342D20434D443A2020433A5C57696E646F77735C73797374656D33325C737663686F7374202D6B2073726D7376637320202D20557365723A204E616D653A204E5420415554484F524954595C53595354454D2C205349443A532D312D352D313820</Binary>
  </EventData>
</Event>
quota1.bmp
quota2.bmp
LVL 2
rhiancohenVMware Senior ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhiancohenVMware Senior ConsultantAuthor Commented:
Hiya,

I have fixed this now by doing the following.

1. Created an AD User account and added the email address into the email field of the properties of the AD account

2. In FSRM > Right click on File Server Resource Manager and select Configure Options > Default email settings > Default Administrator Recipients, make sure the same email address is in here. (In my case it already was but worth checking)

3. In FSRM > Quota Management > Quotas > Right click on your Quota and select Edit Quota Properties > Go to Notification thresholds and click Edit on whichever thresholds you have set up > Under Send email to the following administrators, make sure you have your email address in here as well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rhiancohenVMware Senior ConsultantAuthor Commented:
This solution worked for us. I am still not sure why we needed to have the email address as part of an AD User object for it to work but I can't find any more information about this at the moment.

Other fixes also say don't leave a trailing semi colon if you add multiple addresses into the email fields in FSRM but this wasn't our problem but may help others if you come across this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.