?
Solved

How do I get a Cisco 4507 and a Cisco 2960x to connect with 20GB?

Posted on 2014-08-12
10
Medium Priority
?
1,115 Views
Last Modified: 2014-09-11
Currently we have one of the fiber ports in the 4507 and one of the fiber ports in the 2960 connected and running at 10 Gig. If we plug in the second module on both of the switches nothing happens. What do we need to do to enable and run the second port so we can get 20GB?
0
Comment
Question by:emeschke
  • 3
  • 3
  • 3
  • +1
10 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 40256093
The technically correct answer is "you can't".  Since the 2960 doesn't support anything faster than 10g.

But you can connect two 10g links and use etherchannel to create the appearance of a single 20g link.  But keep in mind that a "flow" of traffic will only use one of the links.  This isn't a problem if the reason for doing this is to accommodate multiple flows of traffic. In which case the different flows will be distributed across the two links.

The configuration is relatively straightforward.

First, make sure all the interfaces involved (on both switches) are configured identically. Which means that things like trunking, allowed VLANs, native VLANs, etc. must be the same on all the interfaces. Then:

conf t
int range ten0/1 - 2
 shut
 channel-group 1 mode active
 no shut
end

Open in new window

0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40258016
Just to add to what Don said, make sure you make any further changes to the operation of the Etherchannel (trunk allowed VLANs, etc) via the Port-Channel interface which will appear after you create the Etherchannel.  If you make changes directly to the interfaces in the Etherchannel they may drop-out and could cause the link to fail.

So, assuming your TenGig interfaces have something like this...
interface TenGigabitEthernet0/1
 switchport
 switchport mode trunk
 switchport trunk native vlan 100
 switchport trunk allowed vlan 1-200

Open in new window


...when you do the config as per Don's post you'll automatically get something similar to the following added to your config...
interface Port-Channel1
 switchport
 switchport mode trunk
 switchport trunk native vlan 100
 switchport trunk allowed vlan 1-200

Open in new window

...for example.  If you wanted to change the native VLAN afterwards you'd do it in the Port-Channel interface, not in the TenGig interfaces.
0
 

Author Comment

by:emeschke
ID: 40261999
Finally got a chance to run the commands. I have all the interfaces configured the same, the port channels are all configured identically but I still don't think things are working. If I do a sho int port-channel 2 it only shows one of the ports as a member. I have attached a snip of the putty session. A sho int transceiver shows the second line dark.
Is there something else i need to do?
PortChannel2.JPG
0
2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

 
LVL 47

Expert Comment

by:Craig Beck
ID: 40262015
Te3/2 and Te4/2 have problems!

Can you post the configs for each interface, and the PortChannel?
0
 

Author Comment

by:emeschke
ID: 40262028
Here they are.
Channel1.JPG
Channel2.JPG
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40262053
Ok so PortChannel2 includes Te3/1 and Te3/2.  We established that Te3/2 has a problem so only one interface will appear active in the PortChannel.  The same can be said for the other PortChannel.

I'd try fixing the links first - chances are the PortChannels will be fine then.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40262181
Please post the output of a "show ether summ".
0
 

Author Comment

by:emeschke
ID: 40262208
Here is the result, looks like I have and issue with those channels.
ShowEther.JPG
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40262233
I would remove the port-channel commands and verify each link is operational (by shutting down one).
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 40262559
Just an idea for the links: based on the transmit power, any chance we're mixing LX and SX optics here?
Tamas
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question