Sharepoint 2003 Searching

Guys

I have setup a new site in Sharepoint 2003 and would like all users to be able to perform searches.  When the do, they are getting error below.

Object reference not set to any instance of an object.  at microsoft.office.server.search.webControls.CoreresultsWebPart.OnLoad
at system Web.UI.Control.LoadRecursive ()
at system Web.UI.Control.LoadRecursive ()
at system Web.UI.Control.LoadRecursive ()

Any thoughts.  Thanks guys
zubby1977Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jayaraja JayaramanSharepoint Architect ConsultantCommented:
1. Should always use ie security zone intranet when adding sites....However, this setting has nothing to do with search....
2. Please ensure that your public URL has an  AAM setting preferably Extranet
0
zubby1977Author Commented:
Can you please be a little more specific
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
please ensure you have alternate access mapping setup up the right way and please make sure you have the intranet/site has been added on ur trusted internet or intranet zone providers in internet explorer
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

zubby1977Author Commented:
I'm still getting the same error
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
Ok, Try adding the machine name to the host file and do a iis reset, reboot would be recommended.
then try search again
just read thro this as well http://texhex.blogspot.com/2008/09/windows-search-server-sharepoint.html
0
zubby1977Author Commented:
Ok, I am almost there.

One thing.
I don't need to edit any AAM, I need to add

http://sharepoint1
https://sharepoint1
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
add your machine name to your AAM and under default/intranet zone
0
zubby1977Author Commented:
What do you mean by this
" default/intranet zone" not sure
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
first add your machine name to your Alternate Access Mapping under intranet zone provider.
0
zubby1977Author Commented:
Remember I have a working site already, so it's there already.
I am just adding a new site because at some point we will be removing the first site.
for example.

1st: site:  sharepoint.companyname.com ( this is already working fine can searching is working perfectly)

2nd site: sharepoint2.companyname.com (we added this site recently but unable to perform searches)

Both sites is exactly the same thing.  We want users to now user sharepoint2.companyname.com and be able to search.
Remember, both sites are the same but different url.

Just wanted to make that clear.

Thanks
0
zubby1977Author Commented:
Ok, I did it and it worked!!!!
Yes.....
0
zubby1977Author Commented:
When you are adding an AAM and it maps to a "public url for Zone, what does that mean"
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
the zone in which yu are setting up the AAM should match with IE zone settings
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zubby1977Author Commented:
Issue resolved.
All these expert comment was extremely helpful,  
Thank  you
0
zubby1977Author Commented:
Why is it that users and being prompted to enter password now everything they try to access sharepoint.  Thanks
0
Jayaraja JayaramanSharepoint Architect ConsultantCommented:
please check the settings on the browser intranet zone,under user authentication-> automatic logon for intranet zone
0
zubby1977Author Commented:
Fantastic.  Issue resolved.
Thanks again
0
zubby1977Author Commented:
Thanks for all your help but one more question please.

1st: site:  sharepoint.companyname.com ( this is already working fine can searching is working perfectly)

2nd site: sharepoint2.companyname.com (we added this site recently)

Issue:

But when users go to sharepoint2.companyname.com it redirects to sharepoint.companyname.com, the original site.

How can we not have the site redirect to sharepoint.companyname.com, but function independently.  
Please help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.