Microsoft webpage opens as blank page

Posted on 2014-08-12
Last Modified: 2014-08-18
This one is really weird and complicated to explain. Last Thursday I picked up a Surface for our PR department and I was setting it up. I was trying to download Framework 2.0 for Remote Manager and the page wouldn’t load. I went to my computer and tried to go to and the page kind of loads. It appears to resolve and load even with a scroll bar but the page is blank. I could go to the ip address of Microsoft and the page would load just fine which says DNS issue to me. I can reboot my computer and get the page display once but then at refresh never again. I can change the DNS on my computer to point directly to TW (Time Warner my service provider), and google dns and it doesn’t work. I connected my computer directly to the TW router with TW DNS and live IP and I could get the website to load. I brought my computer back to my network which my computer just gets DHCP from the router. The router has our two DC’s and one of the TW as DNS in the router. This is what it serves as DHCP. If I change my DNS to our router IP address then I can display the webpage. At first this is telling me that it’s our DNS servers except that they point to TW when they can’t resolve of which when I connect to TW live it works. Then the fact that it works when I direct my DNS to our router is confusing because the router points to our DC’s first before TW. The thing is that it is resolving but not loading. When I switch DNS you can see the website flash then go white. When I log into both DC’s and try to visit the website they load just fine and they point at themselves first then the other DC. However when I go on our new Terminal Server it does not work and it points to our DC's. In general if it was just my computer I would stop there but it’s the same on our phones so that rules out virus scanners and it just being localized. Other IT personnel said today he had a similar problem with the HP site when downloading drivers.

What I have done thus far: Rebooted both TW router and our router. I flushed DNS on both DC’s. Rebooted my PC and was able to get to website but then refresh and just a white page. I don’t know if this is a caching issue but clearing my local cache does not fix it and my phone had issues the first time trying to visit the site. It’s weird that even putting in DNS to go around our DC’s still doesn’t work which made me think it was the router and rebooting it may fix it. However pointing DNS at the router does fix it. Found some people talking about disabling DNS client service and it working for them but it didn’t for me.

Any Ideas?

Question by:RobMes
    LVL 19

    Expert Comment

    Is the router updated with latest firmware?

    Accepted Solution

    Sorry I actually tried to delete this question because I received a solution after 5 minutes in Spiceworks.

    I use a Watchguard 505 router and unchecking the url maximum limit box in the HTTP-Client Proxy of the router. I do not know why this has suddenly become an issue because there has not been a firmware change but most likely triggered by a change in the website itself. The limit was set to 2048 bytes and would even work if I increased the limit to 4096 but I opted to uncheck limiting it all together.

    I wouldn't have found that one without some help so thank you to the Spiceworks free community.

    Author Closing Comment

    Found it in another community that isn't going to charge me $29/month. A community that helped within minutes instead of never getting a reply within 12 hours. I think the exchange is getting a little premature on increasing it's value.

    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    Join & Write a Comment

    Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
    Occasionally you run into the website or two that will not resolve properly using your own DNS servers.  Some people simply set up global forwarders for their DNS server.  I don’t recommend doing this because it can cause problems resolving addresse…
    This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
    How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now