Why will mp4 file not play via an intermediary script on an iPad when it will on all other platforms

We have installed video.js and can use it easily (great program) when directly accessing an mp4 file. ie we call the file directly from the javascript code.

In order to introduce security and stop people seeing the location of the file we changed the file location to be a  .asp file which does a look up on an ID to get the file name and location path from the database and then run the video.

This is simple code and works fine on all computers we have tried it on and android devices ... however it will not play on an iPad or iPhone though. If we hit the mp4 directly the iPad plays it, if we hit the file first it will not.

Does anybody have any idea why not? We do not have access to Apple development tools to troubleshoot it.
LarideAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
That sounds like a 'file association' or MIME type problem.  Do you have the ability to return the correct 'Content-Type' header for the MP4s?

http://en.wikipedia.org/wiki/Internet_media_type
0
LarideAuthor Commented:
We are actually using a PHP file.  We are using the following line of code:

header("Content-Type: video/mp4");

It is also being set up as a 206 return for partial content so we can seek to a particular point in the file to record where somebody has got to and save their point in the file to database.
0
LarideAuthor Commented:
Problem resolved. The headers in the files were not consistent with what APPLE OS is expecting - (I hate APPLE). Running our file through a program called 'Handshake' and ticking the box which 'make it work on APPLE!) solves the issue .... ARGGGHHHH!

I hope this helps somebody else with the same problem in future. It took us 2 days to find this solution.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LarideAuthor Commented:
Solved ourselves.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.