[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

MS Word link in IE opens the document in IE not in MS Word

Posted on 2014-08-12
16
Medium Priority
?
2,972 Views
Last Modified: 2014-08-21
I have a user that is on a website (any website), clicks a link to open a Word document and it opens the doc in IE.  We are set by default to open this type of document in a new window of MS Word.

I am looking for the settings/regkeys to change how this kind of weblink opens an office document.

3rd party software solution is not a solution for us...FYI.

We are running:
Windows 7 SP1
Office Pro Plus 2010
0
Comment
Question by:Mike Schultz
  • 5
  • 4
  • 4
  • +2
15 Comments
 
LVL 20

Expert Comment

by:strivoli
ID: 40257786
If this is a public web site, please post the URL. Thanks.
0
 
LVL 70

Expert Comment

by:Merete
ID: 40257891
Are you asked first what you want to do?
Open or save.
dot doc in IE browserTest one for us paste into IE browser, it is just a story of the internet of things Titled
The Internet Yesterday, Today, Tomorrow
(Doc) http://www.bosrup.com/internet/60/internet.doc
If I open this URL in Chrome it auto saves as a download
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 40258023
have you tried the RESET Internet Explorer option, which may reset the choice of saving/prompting to open.

if not you can also check the registry when signed in as the user:  HKEY_CurrentUser\Software\Microsoft\Windows\Shell\AttachmentExecute

Look for a folder listed as 0002DF01......000000000046 -- this is the folder where IE sticks the filetypes/apps its told not to prompt about.  you might also want to check the Default Programs settings and ensure the DOC/DOCX format is pointing to Word correctly.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Author Comment

by:Mike Schultz
ID: 40258114
If this is a public web site, please post the URL. - I have a user that is on a website (any website) = anything internal or external including now Merete's site http://www.bosrup.com/internet/60/internet.doc.  I get the popup shown in Merete's post "What do you....."

I deleted the following regkey: HKEY_CurrentUser\Software\Microsoft\Windows\Shell\AttachmentExecute and rebooted
   AttachmentExecute  was in user's setting but my registry did not have that entry so I deleted the user's entry

I did RESET Internet Explorer options and rebooted

Work done above did not change a thing.  User is not in a hurry to resolve this so I have a little time to keep digging for a real solution instead of the old standby of resetting his roaming profile.

Thanks for the help BTW it is appreciated
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 40258693
Mike-Schultz --
I am totally confused.
1)  This seems all normal behavior to me.  After I click "Open" in the popup, the site does not open in IE but in MS Word on my PC. ( It takes a while since it is a large document, but it does open in Word. ) The popup is a security warning from IE to help you avoid opening a file that might contain malware.  If you are not sure whether malware is the case, then you can first "Save" and then scan with antimalware apps before opening.
2)  How did Merete know the site was a bosrup.com site, since no mention of that was made in prior posts?
0
 
LVL 70

Expert Comment

by:Merete
ID: 40259773
jcimarron
he is referring to a link I posted as an example, it is a .doc about the internet of things, I sourced it on the internet to find a .doc example so he can test it  when he opens the link, if it he also gets the pop-up, he has confirmed that he does get that as well and is asked the same, what do you want to do!!
This is what I posted for him to test, it my example not his, he did not post any examples.
(Doc) http://www.bosrup.com/internet/60/internet.doc
So your thoughts that maybe he is communicating with me outside of the question is 100% not true.
 thankyou
I cant really see what the problem is? as this is normal behaviour to me as well. What the user chooses is how a .doc opens from a url.
If the user chooses open it opens in the browser is downloaded to the temp, if they choose save or save as then it saves to the downloads and the user has to manually open it it will then open in word.
Maybe this user has also selected to always use use this option open
How do I control how a Word document opens from the internet or an intranet?
http://shaunakelly.com/word/sharing/opendocinie.html
maybe look at the programs settings
internet options programsregards Merete
0
 
LVL 2

Author Comment

by:Mike Schultz
ID: 40260360
Thanks for re-summarizing this again Merete could not have said it again better myself :)

The link http://shaunakelly.com/word/sharing/opendocinie.html unfortunately is for Windows XP and the "click Tools > Folder Options and click on the File Types tab" does not exists in Windows 7, hence my dilemma.

I found tons of solutions for XP but none yet for Windows 7.

W7-File-Associations.jpg
All I can find is the above which only lets you pick the program but has zero options to tweak it for how you want to use it.
0
 
LVL 70

Expert Comment

by:Merete
ID: 40260648
Mike-Schultz
Oh sorry yes of course that is missing my apologies , I have windows 7 as well, it was late .
When I encounter any URL .Doc or PDF I can rightclick it and open in new window and still get the 3 options to open or save or save as in the new windows
If I use the hold CTRL when clicking a link it opens in a new tab.> still get the 3 options to open save and save as.
hold Shift when clicking a link opens in a new window.>> still get the 3 options to open save and save as.
Here is the Google search page, I found it again, I took the URL .DOC from for that Internet of Things, [DOC] The Internet - Yesterday, Today, Tomorrow
https://www.google.com.au/search?sourceid=navclient&hl=en-GB&ie=UTF-8&rlz=1T4GGNI_en-GBAU497AU497&q=The+Internet+Of+Things#hl=en-GB&q=The+Internet+Of+Things+.doc
 using the entire page so I can test this one URL.doc not open it,
I believe because it is a public web page we cannot control how this features is set and is also unsafe.
There is no way it seems to actually make IE 11 not show the open/download prompt when clicking a linked file, as it is a new security measure designed to stop sites from downloading unwanted content to our machines.
Microsoft has designed this new security feature with every user in mind ,
if any user could alter their settings to always open files even in a new tab or new window their system could be compromised, and helping them do this should not even be considered.
It is also against the rules of EE to offer a suggestion that could compromise any users security.

I have noticed in my testing that IE 11 has a few settings differ from the older IE versions in the advanced
If you have tabbed browsing turned off  maybe some settings may not appear in internet options advanced
like this reuse pages
Two different settings internet explorer one missing in IE 11

 Try this one >Open the internet options tabbed browsing open links from other programs in new window


This is great stuff I have bookmarked this for the great tips
How to use and configure Internet Explorer 11 Tabs in Windows 7 and 8.1
http://www.winhelp.us/internet-explorer-11-tabs.html

So my testing results is it can't be done without compromising  the security of the user.
Regards Merete
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 40261187
Mike-Schultz --

Let me rephrase my earlier post, since I am not sure it has been understood.

This seems all normal behavior to me. And I understand Merete agrees. After I click "Open" in the popup, the site does not open in IE but in MS Word on my PC.
 The popup is a security warning from IE to help you avoid opening a file that might contain malware.  If you are not sure whether malware is the case, this allows you to first "Save" and then scan with antimalware apps before opening.

No solution is needed.

And no inference was ever intended that you and Merete have communicated outside E-E.  It is too bad my earlier comment clouded the main message I meant to convey about your original post.
0
 
LVL 2

Accepted Solution

by:
Mike Schultz earned 0 total points
ID: 40262832
I figured it out.

Changing this regkey took care of this issue.  

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8\ BrowserFlags

24 = Open in IE
2c = opens in Word

Thanks for the effort guys, was appreciated.
1
 
LVL 2

Author Comment

by:Mike Schultz
ID: 40264620
I've requested that this question be closed as follows:

Accepted answer: 0 points for Mike-Schultz's comment #a40262832

for the following reason:

While waiting for input on my issue I kept researching the problem and found the solution myself.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 40263483
Mike-Schultz--
It is not a good idea to defeat this security warning.  It is there to protect you from malware that may be contained in downloaded files from the internet.
0
 
LVL 70

Expert Comment

by:Merete
ID: 40264621
I recommend this be deleted!!
Mike-Schultz has found his own solution no need to share it around.
By passing Microsoft security protocols in these times is not encouraged and should not be posted publicly on Experts Exchange It is showing others how to compromise their computer.
Experts Exchange should not be the place to look for solutions to hack or bypass security.
With respect as not intended to convey anything else towards Mike-Schultz good efforts.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 40265200
There are usually several ways to look at things.
I suggest that this thread be kept but that the Accepted Solution(s) be
http:#a40263483
and perhaps
http:#a40259773
as warnings to others why changing this warning window is not a good idea.
0
 
LVL 2

Author Comment

by:Mike Schultz
ID: 40267537
Ok sorry for being a little rude here but did you guys read what I wrote?

Original post:
MS Word link in IE opens the document in IE not in MS Word

I did NOT say I bypassed the security popup.  The regkey I changed did what I said:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8\ BrowserFlags

 24 = Open in IE
 2c = opens in Word

The security popup is still there it just opens in the Word app or IE if changed.  Not once did I say I want to get rid of the popup, I just said I get the popup.

I do appreciate the effort you guys put into this though.  Thanks again for trying to help.
1

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question