Users unable to delete files from their own desktop in RDS 2012

Posted on 2014-08-13
1 Endorsement
Last Modified: 2016-03-21
Hi there

We have an RDS environment running entirely on 2012 R2 session host servers.  User profile disks are in use to store user settings, desktops etc.

Users, obviously, do not have administrative permissions on the server.  We are currently experiencing an issue where users are unable to delete anything on their own desktops - even though they have full permission to it.  Creating a file there works fine, and the correct permissions are granted - system full control, Administrators full control, and the user full control - inherited from c:\users\<user>\desktop which maps from their UPD.

However when they try and delete a file they've just created, they get a UAC prompt, and are then denied access when they enter their own details.  Administrators on the server do not have this problem when trying to delete their own files.

Wyse TCX is running on this server, but don't think it will be a culprit.  Any ideas as to what the issue may be?


Question by:chris3879
    LVL 23

    Expert Comment

    I have seen this issue once with permissions we've created on a directory were users had their profile stored. Eventually the issue was that the Domain users group (or whatever group you need) needed to have list access from top to bottom to be able to change these files (in our case eventually being the D drive itself).

    You could also try and redirect the desktop, might that be an option??

    Accepted Solution

    Just to feed back on this issue, it was actually caused by a rogue recycle bin in the default user profile disk template VMDK.

    This created a recycle bin in the root of the user's profile disk, which had funny permissions, and wouldn't let the user themselves create anything within it (as only Administrators had write) - so deletions wouldn't work.  Shift+del worked, which is what pointed us at the bin itself.

    I mounted the VMDK template, deleted the recycle bin from within the root of it, and created a new user.  Logged on, and it created the recycle bin with the correct permissions, and all was fine.  Existing users I had to mount their UPD manually, delete the same folder, and then get them to log on again, and it fixed it from their profiles too.

    A tiny cause of a big problem - so hope this helps someone!


    LVL 33

    Expert Comment

    Awesome! Thanks for posting the solution. I had the same exact issue and your solution fixed the problem.

    Author Comment

    Great! Glad posting the solution helped.



    Author Closing Comment

    Troubleshot and solved the issue
    LVL 1

    Expert Comment

    which folder had to be deleted to correct the issue?

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
    You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
    In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…
    This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now