• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6417
  • Last Modified:

Windows 2012 Remote Desktop just stopped working after a reboot

Hi
I have installed Remote Desktop on a DC for the moment but in next school holidays I will seperate them.
However with windows 2008 and 2003 this has been working like a sharm last 10 years so unless 2012 makes this senario worse i dont think that is the issue here

See attached.
Installed the remote access tools
All we use is to connect to remote desktop like we have done all the way since 2003.
IT worked well for a week
I have not activated the lisesce but have 103 days left. I know when i activate the lisence server, i will get issue with older version of RDP on so thats why its not activated jet as I have no solution on this

THen yesterday I did a reboot due to some internet issue and now I can not connect to remote desktop,
It just says:
The Compunter can't connect to the remote computer
Try connecting aain, if the problem continues, contact the owner of remote computer or your network administrator.

I do not even get to the logon box

I have also right clicked "My Computer" --> Properties --> Advanced System ->Remote.
Remote Desktop option to allow or dont allow is greyed out,but its marked on "Allow"
I have taken away the tick of using "Network Level Authentication" as this causes the older client not to work

Any idea where to start looking for the problem?
rds1.jpg
rds2.jpg
0
morten444
Asked:
morten444
  • 4
  • 3
1 Solution
 
Lionel MMSmall Business IT ConsultantCommented:
If you aren't getting any other error I would start by checking the firewall--I assume this reboot was due to a Windows update? You can easily test if it is a firewall issue by turning off all firewalls momentarily and see if you can then connect--which firewall(s) are you using? and what is your virus software?
0
 
morten444Author Commented:
Hi
Thanks for your reply
ITs a totally new server so I have not added any antivirus or 3rd party firewall.
I can see there is a windows firewall but that I have disabled

I have kind of started from the start again
1. I have uninstalled all Remote Desktop roles and restarted
2. The greyout "remote desktop" under setting is now not grayed out. Deleted some register keyes
3. I have set it to allow to connect with remote desktop

Now i do some test. The server is called terminalsrv.magleby.dk and has IP 192.168.1.5

On the server i do the following 2 test
try to connect with remote desktop using IP. It says its not availabe
I then try to connect with terminalsrv.magleby.dk and then it works

I then repeate the test on a windows 7 PC on the network
Try to connect with IP.. Does not work
Try to connect with terminasrv.magleby.dk. Does not work

When it all worked i was able to connect with the IP without writing port numbers, so I guess that as soon as i get it to work with an IP again it will work

I am doing further test but only with Remote Desktop Management and not with the roles installed

Hope you have any idea

Thanks again
Morten
0
 
Lionel MMSmall Business IT ConsultantCommented:
are you using custom port number of the defaults--if custom you MUST add the port number to the ip address example 10.10.10.10:33191
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
morten444Author Commented:
Hi
Nope I am using standard 3389 port
During PD i am only trying on the server at the moment as first step must be i can connect width RDP from the server using IP

From the server i can connect using terminalsrv.magleby.dk but i can not connect with 192.168.1.5 or 192.168.1.5:3389

its strange as DHCP Server is using 192.168.1.5 as DNS and ipconfig on client pc also shows that the server is the DNS
Can it be something with security certificates only allowing to use domain name?
Is there a way to disable all this so its using no security just for testing
I found a setting in Group Policy where i set autentication from negosiate to RDP, as i throught that was with no security but no joy.

Its very strange. I am logging on as Administrator on the server when testing to make sure there is no permission issues

Help!! :)
0
 
morten444Author Commented:
Hi
Issue has been resolved
Very strange. It still worked only with domain name. not with IP
I had already uninstalled Remote Desktop role during testing
I then tried to install it again and bingo.. it started to work.
I have done this several times already so not sure what was different this time
Thanks for your replies and I give you points for comming back to me with valid suggestions
Regards
Morten
0
 
Lionel MMSmall Business IT ConsultantCommented:
Frustrating when it starts to work and you don't know why--hope it stays resolved
0
 
morten444Author Commented:
Yes cant agree more!!
Thanks
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now