• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 516
  • Last Modified:

Configuring IP Phones Mac Address

I am using 2 Windows VM machines with IP Communicator installed on each (IP phone emulator.)
On GNS3 I have cisco router with IOS 12.4, I configured telephony service on it by running the Setup command line.
The set up assigned MAC addresses and line buttons automatically. In real World with real IP Phone hardware that comes with their own Mac addresses , you may have to configure that manually...
I would like to know how to do that ?

I am not sure if I was not supposed to run the command Setup, and type whatever it has prompted to type.

Any help will be very much appreciated.


 Thanks


R2#sh run
Building configuration...

Current configuration : 1519 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.137.1 192.168.137.5
!
ip dhcp pool MyPool
   network 192.168.137.0 255.255.255.0
   option 150 ip 192.168.137.2
   default-router 192.168.137.2
   domain-name wr
!
!
!
!
!
!
!
!
!!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.137.2 255.255.255.0
 duplex half
!
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 4
 max-dn 4
 ip source-address 192.168.137.2 port 2000
 auto assign 1 to 4
 create cnf-files version-stamp Jan 01 2002 00:00:00
 max-conferences 4 gain -6
 transfer-system full-consult
!
!
ephone-dn  1  dual-line
 number 1000
!
!
ephone-dn  2  dual-line
 number 1001
!
!
ephone-dn  3  dual-line
 number 1002
!
!
ephone-dn  4  dual-line
 number 1003
!
!
ephone  1
 mac-address 000C.29D4.C3C7
 type CIPC
 button  1:1
!
!
!
ephone  2
 mac-address 000C.299D.812F
 type CIPC
 button  1:2
!
!
!
ephone  3
!
!
!
ephone  4
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

R2#

Open in new window

0
jskfan
Asked:
jskfan
  • 3
  • 2
3 Solutions
 
eeRootCommented:
A physical IP phone would have its MAC address set by the manufacturer.
0
 
jskfanAuthor Commented:
I know that MAC is assigned by the manufacturer.

When you get new IP phones, you will need to specify on the router configuration that:

Phone with MAC a2d1452, will have extension 333

what is the command line to do that ?

Thanks
0
 
José MéndezCommented:
ephone  2
 mac-address 000C.5555.6666
 type <new type>
 button  1:4   -->> this means button 1 on the phone will have ephone-dn 4

You already know what to do from the show running above, sounds strange that you ask how.  Maybe if you clarify?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
jskfanAuthor Commented:
In the Show running config I posted. I used an IOS version, that has Setup command , I believe it was under Telephony-Service.
When I typed Setup, I got several prompts , like number of phones and extensions....but never got a prompt to enter Mac Address... So the Setup put there automatically
0
 
José MéndezCommented:
Ah! Got you know. So yeah, that chunk of config that I put before should be the one you need for a new phone. If you type

type

and hit the question symbol, it will display the type of phones you can associate.
0
 
jskfanAuthor Commented:
Thank you
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now