Cannot access NetApp Filer using entry in hosts file

I have a netapp filer named filertemp (192.168.80.2). this is a backup filer. my prod filer is filerprod. If i put an entry in the hosts file of my windows 2008 r2 server that says:

192.168.80.2          filerprod

whenever i use an UNC path (\\filertemp\sys1)  it says that the server cannot perform the requested operation. If i use telnet or HTTP and access filerprod it works and goes to the filertemp.

I'm not sure why it wont let me access it. I even setup an additonal NetBios name on the filer using filerprod but it still doesn't let me access.

one thing to note is that our linux servers have no problem accessing it using the name filerprod but having it pointed to the filertemp IP.
LVL 2
msidnamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

robocatCommented:
See if this helps (on filertemp):

options cifs.netbios_aliases filerprod
0
msidnamAuthor Commented:
I still get the same errors. if i run wireshark i get errors that i've attached.

Connecting to filer UNC
0
robocatCommented:
It's probably security getting into your way.  

SMB checks for name of file share server in SMB request. If this name differs from the actual server name, the request is denied. It is the same reason why you can't use a DNS alias pointing to a file server, we never got this to work either.

Linux probably uses an older, less secure protocol version, allowing this to work.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
msidnamAuthor Commented:
Thank you robocat. I did a test yesterday. I removed my DNS servers on the computer i was trying to access the share from. I also clicked enable NetBios over TCP/IP in the network settings. I rebooted and then tried to access the share. It prompted me for a username and password and it let me in. I did this on a windows 2003 server but i could not do it on a 2008R2 server. I guess the security is even more strict (perhaps because of SMB2?).

Thank you for your help. At least i know now that I'm not the only one.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.