[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5417
  • Last Modified:

Internet Explorer does not prompt to remember password for a specific web site, how to enable?

One specific web site.  A few weeks ago I opt'ed to not remember password for a specific web site.  But I have since  changed my mind and want IE to remember the web site's password for me.   However I can't figure out how to get IE to prompt me again to remember password for that web site again.  How to get IE to remember the password?       It's not the web site's fault since I have other computers nearby which remember this website's password just fine.    No 3rd party browser password managers are involved in this question.    Thanks.
0
JReam
Asked:
JReam
  • 3
  • 3
  • 2
  • +2
3 Solutions
 
RayData AnalystCommented:
Likely, you have in the past said 'never' when asked to store a password for this website.  Rather than try to 're-invent the wheel', here is an excellent resource to resolve this issue for you.

http://blogs.msdn.com/b/ieinternals/archive/2009/09/10/troubleshooting-stored-login-problems-in-ie.aspx
0
 
John HurstBusiness Consultant (Owner)Commented:
You can try two things:

1. Go to IE, Tools, Internet Options, Content, Autocomplete settings and delete Autocomplete to start again. Then click on Manage Passwords and see if the site in question is there. Delete it. Then restart IE and test.

2. If no luck, do an IE Reset. Go to IE, Tools, Internet Options, Advanced and Reset. You need to restart the computer after this is done.
0
 
Thomas Zucker-ScharffSystems AnalystCommented:
I would like to answer the question, but feel I need to offer an opinion instead.  You should NEVER have your browser remember passwords to any websites.  This is just asking to be compromised.  The very first place malware will look for identity information is in your default browser.  The assumption is that it has only a few moments before the system's malware detection program will discover its existence and remove it or at least try.  Therefore, malware is programmed to look in the most likely place for user passwords and such and that place is your browser.

So Just don't. My two cents worth.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
JReamAuthor Commented:
rlistenb & john,  thanks for the replies.   I read the blog and tried both of John's suggestions.  

Here's the webpage in question, GoDaddy's online browser email application:
     https://login.secureserver.net/index.php?app=wbe

I've tried all the suggestions including
  - Delete Browsing History , all items selected.
  - Full IE Reset
  - The blog's utility called "IE Password Remember Tool" , which does NOT find an entry for https://login.secureserver.net
  - Registry, HKCU\Software\Microsoft\Internet Explorer\IntelliForms\ , deleted everything I could find under there...
0
 
John HurstBusiness Consultant (Owner)Commented:
You can try a more aggressive repair.

Go to Windows Features (Programs and Features) and remove IE. This forces a restart so allow that.  Go back to Windows Features and add IE back in. This forces another restart. Allow that.

Reset IE again for good measure and test again.
0
 
JReamAuthor Commented:
Yes that's an aggressive repair idea!   I went ahead and did it anyway.     Basically I did a total uninstall of Internet Explorer 8 and I reinstalled it from scratch.     I haven't mentioned it up to now, but this computer is running Windows XP (all SPs) and MS IE 8 (all updates).   It's a solid system, the 3rd PC on my desk, and serves a narrow but important role for me.    I honestly don't think that XP vs W7 matters at all in this discussion.

After reinstall IE8 unfortunately the same issue exists.   "Save Password" prompt is not happening,  only on that particular webpage for GoDaddy; https://login.secureserver.net.  For all other webpages yes I get prompt to save password

Yes a while ago I inadvertently opt'ed to not remember password for this specific web site.  But I have since  changed my mind and want IE to remember the web site's password for me.  

I think there's got to be some obscure registry setting someplace... (not HKCU\Software\Microsoft\Internet Explorer\IntelliForms\ since I tried deleting that one already.)
  I also don't think it's in HKCU since I tried creating a new local user account from scratch, logged in, same issue.

Chrome:   I installed a copy of Chrome and it does indeed prompt and save the web site's password as expected.    I guess I could dump IE and go with Chrome on this particular PC...  but I would have really preferred to resolve the original IE issue and avoid using an entirely different browser application.
0
 
☠ MASQ ☠Commented:
For your average end user this is almost impossible!  IE stores all of your decisions about saving passwords in a hashed log file which it checks against every time the browser sees a password request.  As John says above one way of addressing that is to wipe your auto-complete record entirely but this means all your other settings will be lost too.

A couple of years ago Eric Law - one of Microsoft's IE developers and an MVP put together a really simple utility called IERememberPassword which allows you to change your previous decisions for individual URLs rather than changing them all.

You can read about it and download from his site:
http://blogs.msdn.com/b/ieinternals/archive/2010/04/09/restoring-the-internet-explorer-password-autocomplete-prompt.aspx

This feature was never incorporated into IE and Eric no longer works for Microsoft (although is still recognised as an MVP)

EDIT - see that you've already found Eric's util though rlistenb's blog link.
Strange that GoDaddy isn't appearing in the list - maybe have a look at the source code on the login page and see exactly what is calling the password. It's also worth trying cutting and pasting the URL from the page in IE directly into the Utility window.
0
 
JReamAuthor Commented:
Very frustrating, I tried everything.   I'll have to abandon IE on this particular PC and go with Chrome exclusively.   I don't give up on stuff like this very often, but this one has me truly stumped.  A rare moment.  

I tried Eric's utility numerous times in fact using every incarnation of the URL I could think of, the HASH was never located.
John Hurst's suggestion of Full Reset, and complete uninstall & reinstall, unfortunately didn't make a difference either.
I guess it must be something about the HTML rendered that we see client side from https://login.secureserver.net, although nothing looks improper to me.  Maybe javascript is amiss somehow on PC client side.    

Closing the question, nothing more can be done, thanks.
0
 
John HurstBusiness Consultant (Owner)Commented:
@JReam  - Thank you for updating us. Good luck with your move to Chrome.
0
 
RayData AnalystCommented:
Sorry none of us could provide you with a solution or at least a start the led to one.  Thanks for the update on your selected final resolution.
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now