[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Can't access Windows 2012 Server via RDP

Posted on 2014-08-13
21
Medium Priority
?
508 Views
Last Modified: 2014-08-18
Hi,

Having an issue connecting to a new Windows 2012 server via RDP. I have done some searching on this and I have tried setting the ports explicitly in the firewall and allowing any remote access and those changes didn't work. I can access the Internet from the server and even RDP to another server, but I can't access it from another machine.

This is driving me crazy, as I know it must be something silly.

Thanks.

Chip
0
Comment
Question by:cwemely
  • 11
  • 4
  • 3
  • +2
21 Comments
 
LVL 14

Expert Comment

by:dejaanbu
ID: 40258852
what is the error are you getting?
can you able to ping the server?

check whether the port is open on the server using the following command from other machine
telnet (type your server name or IP Address here) 3389

Uncheck the option [Allow Connections only from computers running remote desktop with network level authentication (recommended)] from remote setting
0
 
LVL 3

Expert Comment

by:Sean Fitzpatrick
ID: 40258957
Do you have RDP enabled?
Is your firewall enabled? Have you enabled RDP through your firewall if it is?
0
 

Author Comment

by:cwemely
ID: 40259004
Hi dejaanbu - I am not getting any error. It just won't connect. I can't ping the server either. Tried the telnet to that port with no success. Already unchecked the "Allow connections. . . " box.


Hi Sean - Yes RDP is enabled. Firewall is enabled and I tried disabling it. No joy.

To All - I discovered that I can ping and RDP to this server from another server on the same subnet,, but I can't form another subnet. I have tried changing firewall rules on our Cisco firewall without success.

I set another server up at the same time and it is working just fine. I can't figure out what is different about this machine.

Thanks.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
LVL 3

Expert Comment

by:Sean Fitzpatrick
ID: 40259033
Check your routing/VLANs, are you not able to access the 'server' network from the machine you are attempting to RDP/ping from?
0
 
LVL 14

Expert Comment

by:dejaanbu
ID: 40259037
since you can't ping , try to trace the network communication from other subnet to this problematic server
0
 

Author Comment

by:cwemely
ID: 40259053
Sean - The frustrating part is that I can ping and RDP to another server I made at the same time with no issue. The communications to that network are working.

Dejaanbu - How would I trace the network communications to that server?
0
 
LVL 14

Expert Comment

by:dejaanbu
ID: 40259063
go to command prompt and type "tracert (ipaddress of problematic server)"

more info about tracert here:
http://support.microsoft.com/kb/162326
0
 

Expert Comment

by:Julian Green
ID: 40259097
Check the subnet mask on that server.  Is it the same as the other server on the same subnet?   Do both have a gateway defined?   Is your client machine able to RDP/ping the other server?
0
 

Author Comment

by:cwemely
ID: 40259160
OK. Here is the current scenario:

1. I created two identical servers at the same time on the same network.
2. The only difference off the bat was that Windows declared a public network on the server having issues. I changed that to private.
3. I can ping and RDP to the good server from another network. I can't ping or RDP to the problem server from another network.
4. I can ping and RDP to the problem server from the good server on the same network.

So . . . with those four facts, I can't figure out what is the issue. If it was a network to network issue, I wouldn't be able to get to the good server. If it were an issue with the problem server, I wouldn't be able to access it from the good server.

More thoughts?

Thanks.
0
 

Expert Comment

by:Julian Green
ID: 40259174
An incorrect subnet mask would cause this kind of issue.   Also, when you disabled the firewall during troubleshooting, did you stop the service or disable it on the "profiles" (domain/public/private)?
0
 

Accepted Solution

by:
cwemely earned 0 total points
ID: 40259207
OK. I was able to fix it. All I did was to change the IP address. That was it. I don't know why, but it worked.

Thanks for your help and suggestions.
0
 

Author Comment

by:cwemely
ID: 40259403
OK. This is really strange. I changed the IP address and it worked. But, now it won't again! I didn't do anything different. I will try changing IP address one more time.
0
 
LVL 3

Expert Comment

by:Sean Fitzpatrick
ID: 40259482
what is the setting for the network location set to? home/public/work or is it finding the domain?

http://windows.microsoft.com/en-us/windows/choosing-network-location#1TC=windows-7
0
 

Expert Comment

by:kyokusanagi
ID: 40259810
1. Check Remote Desktop Settings
2. Configure the allowed program features in Windows firewall
3. Configure the Inbound of Remote Desktop in Windows firewall advance Settings

This will solve your problem as long the ip address config is correct.
0
 

Author Comment

by:cwemely
ID: 40259874
Sean - Network location was set to Public when I first setup the machine. I changed it to private. It is not on a domain.

Kyokusanagi - 1. Done; 2. Done; 3. Done. Still no joy. I even specified an additional rule for port 3389 as I read a post that sometimes Server 2012 doesn't let RDP in by specifying the program alone.

BTW, now four hours later and the second IP address change now doesn't work. It works as soon as I change it and then stops working after a period of time. I have done this twice to test.

Thanks.
0
 
LVL 3

Expert Comment

by:Sean Fitzpatrick
ID: 40260495
Silly question: You do have RDP enabled on the server right? If your looking at the server management window it says Remote Desktop - Enabled?
0
 

Author Comment

by:cwemely
ID: 40261416
Issue not yet resolved.
0
 

Author Comment

by:cwemely
ID: 40261419
Sean - Yep. Triple-checked every setting.
0
 

Author Comment

by:cwemely
ID: 40261780
OK. Further update. When I use NAT on the local address it causes the server to stop responding to RDP. When I remove the NAT, I can RDP to the server, but I still can't ping.

I tested this again and it works until I enable NAT.

Weird! Thoughts?
0
 

Author Comment

by:cwemely
ID: 40262088
Finally resolved issue. It was a setting on the network firewall that was different between the two.

Thank you for your help!
0
 

Author Closing Comment

by:cwemely
ID: 40267263
I was able to resolved the issue by changing IP addresses.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
Resolve DNS query failed errors for Exchange
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question