Trying to set group policy to never put the system to sleep

Posted on 2014-08-13
Last Modified: 2014-09-05
I am trying to setup a general purpose lab computer to never go to sleep, no matter what user is logged in.  This is a Windows 7 Pro computer.  I went into gpedit.msc, under Computer Configuration\Administrative Template\System\Power Management\Sleep Settings\Specify the Unattended Sleep Timeout setting.  In there, it says that if you enable this policy and specify 0 seconds, Windows will not automatically transition to sleep.  I made this change, but the computer still goes to sleep based on the power scheme settings for each user.  I assumed that group policy is the "authority" of the computer and would at least set each user profile to never go to sleep, but this is not the case apparently.  What am I doing wrong?
Question by:jbobst
    LVL 21

    Accepted Solution

    you can use command line using powercfg tool to disable sleep option

    c:\windows\system32\powercfg.exe -change -monitor-timeout-ac 0
    c:\windows\system32\powercfg.exe -change -monitor-timeout-dc 0
    c:\windows\system32\powercfg.exe -change -disk-timeout-ac 0
    c:\windows\system32\powercfg.exe -change -disk-timeout-dc 0
    c:\windows\system32\powercfg.exe -change -standby-timeout-ac 0
    c:\windows\system32\powercfg.exe -change -standby-timeout-dc 0
    c:\windows\system32\powercfg.exe -change -hibernate-timeout-ac 0
    c:\windows\system32\powercfg.exe -change -hibernate-timeout-dc 0

    this question was asked many times on the group and they have ended with command line option

    below are ref:
    LVL 1

    Author Comment

    So what you are saying is that gpedit.msc console with all those options will not work?  Why does Windows include this if it doesn't work and we have to resort to command line options?
    LVL 21

    Expert Comment

    by:Haresh Nikumbh
    only setting Specify the Unattended Sleep Timeout setting. will not work, you have to disable hibernet as well as display adapter options too.
    LVL 77

    Expert Comment

    by:David Johnson, CD, MVP
    Is this what you have set in group policy?
    Machoine Settings
    LVL 1

    Author Comment

    I actually have "Specify the Unattended Sleep Timeout (Plugged In)" option enabled and set to "0" so it never goes to sleep.  These are desktop systems and will never be on battery.Untitled.jpg

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Wish Marketing would stop bothering you?

    Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

    Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found listed in my profile here: http:…
    New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
    This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
    The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now