[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Unable to get Red Hat Enterprise Linux 5 (64-bit) to get connected to Internet

Posted on 2014-08-14
23
Medium Priority
?
261 Views
Last Modified: 2015-03-11
Hi there,

Just need some help in getting our Virtual Machine connected to the network.
Its a Red Hat Enterprise Linux 5 (64-bit).
I've tried almost everything.
Even edited the config files /etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/networking/devices/ifcfg-eth0

/etc/sysconfig/networking/profiles/default/ifcfg-eth0

However no luck
Any help would be greatly appreciated.

Thanks
0
Comment
Question by:Clement P
  • 11
  • 7
  • 4
  • +1
23 Comments
 
LVL 7

Expert Comment

by:multimac
ID: 40260180
Did you try tui?
yum install system-config-network-tui

Open in new window

system-config-network-tui

Open in new window

0
 
LVL 13

Expert Comment

by:Sandy
ID: 40260186
just run

#setup

and then configure network... else try running #dhclient

TY/SA
0
 
LVL 2

Author Comment

by:Clement P
ID: 40260209
Hi Sandy,

I've tried this as well.
Its showing the Statsic IP and DNS address that I added.


Thanks
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 13

Expert Comment

by:Sandy
ID: 40260213
yes... now..

#service network restart

#ifconfig -a

TY/SA
0
 
LVL 2

Author Comment

by:Clement P
ID: 40260231
Yeah ...I restarted the network services several times yesterday and even today.
It is able to Bring-up the interface eth0 on which I've static IP
Pic1.JPG
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40260236
then where is the prob ? are you able to ping your gateway ? if yes then did you setup in config while configuring the ip ?

Still if gateway is configured then did you checked dns entries in /etc/resolv.conf

put

nameserver 4.2.2.2
nameserver 8.8.8.8

TY/SA
0
 
LVL 2

Author Comment

by:Clement P
ID: 40260248
yeah I did add our internal DNS Server add
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40260254
so what exactly the error then.. if gateway is pinging . if name is getting resolved... then it is not your system who is blocking the access...

Try one more thing..

1. #service iptables stop

2. #service iptables status

MUST BE STOPPED and then try to access.. if still not working then it is network issue or intermittent issue.
0
 
LVL 2

Author Comment

by:Clement P
ID: 40260386
Hi Sandy ,

The problem is we are not able to ping to gateway itself.
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40260396
ok.. what is the gateway IP and the subnet mask ??? if this is the VM then is the bridge/network config is correctly selected ?

Check both your system and gateway ip should be in same subnet.. also please paste

#route -v

TY/SA
0
 
LVL 2

Author Comment

by:Clement P
ID: 40260781
Hi Sandy,

192.168.10.254 , 255.255.255.0
0
 
LVL 62

Expert Comment

by:gheist
ID: 40261629
Is your netcard still eth0?
remove /etc/udev/rules.d/70-*.conf
and reboot to make it eth0 again.
0
 
LVL 2

Author Comment

by:Clement P
ID: 40262581
Hi gheist,

Thank you and  i'll try what you suggested now.

@ Sandy Happy Independence Day :)
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40262586
Thanks a ton for the wishes :)
0
 
LVL 2

Author Comment

by:Clement P
ID: 40262587
Hi gheist,

I don't see 70-*.conf
Pic2.JPG
0
 
LVL 13

Expert Comment

by:Sandy
ID: 40262678
it is in 60-net.rules as this seems RHEL/CENTOS 5 to me.. .but i don't think that you need to do as in earlier screenshot it is eth0 and it is up.. moreover you can put the output for gheist observation :)

#dmesg | grep -i eth

TY/SA
0
 
LVL 2

Author Comment

by:Clement P
ID: 40262811
This is a RHEL Server release 5.8 (Tikanga )
0
 
LVL 62

Expert Comment

by:gheist
ID: 40262971
60-net is the good one. It renames interfaces so that same MAC address is named same all the time. If you delete the file interfaces get re-numbered starting from eth0 and new persistent config file is placed back.
0
 
LVL 2

Author Comment

by:Clement P
ID: 40263385
Hi Gheist,

I've removed the 60-net.
What do I do next please ?

thanks
0
 
LVL 2

Author Comment

by:Clement P
ID: 40263606
route -v screenshot
route--v.JPG
0
 
LVL 62

Expert Comment

by:gheist
ID: 40264002
reboot an you will get 1st adapter eth0. Make sure ifcfg-eth0 has no MAC address inside and it will be configured with good config
If not go to system-config-network and verify all settings and try to bring network interface up.
0
 
LVL 2

Author Comment

by:Clement P
ID: 40658405
I've requested that this question be deleted for the following reason:

delete
0
 
LVL 62

Accepted Solution

by:
gheist earned 2000 total points
ID: 40658406
Reboot helped?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month19 days, left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question