Folder redirection not working correctly

I have applied folder re-direction to a particular user called User A. User A is used to logon to 8 desktops which are Windows 7 Prof computers.  I then went to the redirected folder  which is redirected to a file server and applied read permissions to the My Documents folder and the Desktop folder to prevent User A from saving data locally  in My Documents folder and on the Desktop. Redirection worked on 2 desktops, however when l turned on the other desktops and logged in  as User A folder redirection was not being applied. All the desktop are part of a Windows 2008 domain. I would appreciate you assistance
LVL 1
Phil MapfumoInfrastructure EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Neeraj KumarSystem adminCommented:
Kindly check the below mentioned things :

1. Working & Non working Pc's are in same ou. If they in different OU then policy will not apply
2. Run gpresult /r on non working pc's and check folder redirection policies is showing in applied group policy section or not
3. Also check from non working Pc's file server path is accessible or not.
4. Check event viewer if there is any error related to group policy in application log
0
Neeraj KumarSystem adminCommented:
Ignore 1st point as it is not applicable because folder redirection is user based policy. check rest 3 points
0
rhandelsCommented:
My guess would be that the policy holds the option "move data to new location". If the user has information on his desktop or my documents the policy will try to move the files to the new location. Due to the fact that only has read permissions there the policy will fail to be applied.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Phil MapfumoInfrastructure EngineerAuthor Commented:
Hi rhandels, l have removed the read permissions on the folders and have assigned modify permissions for User A and ran a  GP update but the folders are not being redirected. Neeraj, l have checked event viewer and l get an error that says "Failed to apply policy and redirect folder  Desktop, to "\\server01\folder redirect\imaging\desktop" The following error occurrred:  Cannot create folder "\\server01\folder redirect\imaging\desktop"
Error details :This security ID may not be assigned as the owner of this object"
0
rhandelsCommented:
Please look at the following (short instruction).

User Configuration --> Policies --> Windows Settings --> Folder Redirection --> Desktop.
Right Click Desktop and choose Properties.
Click the second tab Settings.

Look if the option "Move the contents of Desktop to the new location" is ticked. If so, untick it. What it does is copy information from the old desktop location to the new desktop location.
Due to the fact that the user only has read permissions on the new desktop location files or folders cannot be copied that way, hence the policy not being applied.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Phil MapfumoInfrastructure EngineerAuthor Commented:
Okay thanks l will give it a try and get back to you.
0
Phil MapfumoInfrastructure EngineerAuthor Commented:
I did not manage to get this working via GPO however, thank you for your help. I found that the most effective method was to go to each of the desktops and apply read permission directly to the  my documents and my desktop to prevent users from saving in both locations.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.