Remote desktop connection

Posted on 2014-08-15
Last Modified: 2014-08-25
I have a business owner that needs Remote Desktop to his Windows 2008 R2 server. I created the Remote Desktop Session Host in the server, but when I tried to add him as a remote user I got an error:
Windows cannot process the object with the name "(username)" because of the following error: The specified domain either does not exist or could not be contacted.
Do I need to create an Active Directory Domain Services group to make this work?
Question by:Albatross1953
    LVL 14

    Accepted Solution

    If he needs simple remote desktop why did you create a Remote Desktop Session Host? Standard remote desktop allows for two users to be connected simultaneously to a server or PC without any additional configuration.

    If the user you're trying to add to the server is part of a domain, the server needs to have access to a domain controller within that domain for authentication. Otherwise, you'd need to create a local account.
    LVL 1

    Assisted Solution

    Try removing and then readding the RDP server to the domain.  Make sure that the user is part of the Remote Desktop Users group in Active Directory.  If that doesn't work, you may also want to check the default domain controller policy and make sure that there isn't a settings int he User RIghts Assignment that limits who can log onto an RDP server.
    LVL 11

    Assisted Solution

    As said above it's not necessary to create the Remote Desktop Session Host.
    You can check if Remote Desktop is enabled via Control Panel |System |Remote settings
    It's preferred to select "Allow connections from computers running Remote Desktop with Network Level Authentication (more secure)."
    Only if the user is accessing the server from a Windows XP client select "Allow connections from computers running any version of Remote Desktop (less secure).
    After this is set then click "Select Users" and add the necessary user which needs access.
    This user will then automatically be added to the "Remote Desktop Users" group of the server.
    Adding the user to the Remote Desktop Users group in Active Directory will probably give the user the permissions to logon via RDP to the domain controllers.
    LVL 12

    Assisted Solution

    by:Steven Wells
    You will also need to check how he is logging in. From experience you need to specify the login domain in the Remote Desktop client if connecting remotely,   ie domain\username
    as it may and try and use the domain or local computer name from the remote computer.

    also agree with other comments above.

    Author Comment

    I'm back at the site today & trying to make Remote Desktop work. I removed the Session Host. When I go to the Remote Desktop Services Manager & try to add a user, I browser to the computer to add but get the error " The specified domain either does not exist or could not be contacted." That computer is currently logged onto the local network.
    LVL 11

    Assisted Solution

    Can you check if the network connectivity to the domain is ok.
    From a command prompt please try a:
    ping <domainname>,  e.g.
    ping domain.local

    Open in new window

    Some other test are described here:

    If you get a reply from the ping and the network connectivity is fine then you might try KHSIT suggestion.
    Before executing:
    1) Please make sure that you have a local user account with Administrative permissions
    2) Verify that you can logon with this account to the local computer
    3) Make sure you have a domain user account and password which has permissions to re-add the server to the domain.
    4) Check if it's possible to reboot the computer a few times.

    Remove the server from the domain via:
    Control Panel |System |Advanced |Computer Name tab
    Click Change...
    Change "Member of" to Workgroup and fill in WORKGROUP
    Click OK several times and reboot the server

    After the server is back online:
    Control Panel |System |Advanced |Computer Name tab
    Click Change...
    Change "Member of" to Domain and fill in your domain name, e.g. domain.local
    Click OK and fill in the domain account/password which has the permissions to add the server to the domain.
    Click OK several times and reboot the server

    Author Closing Comment

    Browsing to the PC gives an incorrect name structure. It had to be entered manually.

    Featured Post

    Want to promote your upcoming event?

    Is your company attending an event or exhibiting at a trade show soon? Are you speaking at a conference? Spread the word by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

    Join & Write a Comment

    Suggested Solutions

    At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
    Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
    This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
    This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now