Sharepoint 2010 Foundation Search - not working now

Posted on 2014-08-15
Last Modified: 2014-08-26
I have a SharePoint 2010 Foundation system (multiple sites). The search stopped working. I believe it was after I had to change my network administrator password. Once I changed the password (I think) is when this stopped. I keep getting the error:

The search request was unable to connect to the Search Service.
Question by:allenkent
    LVL 14

    Expert Comment

    by:Brad Groux
    From a PowerShell window on the SharePoint server run a Get-SPEnterpriseSearchServiceApplication CmdLet, hopefully it returns the search service. If a search service does not exist you need to create one using New-SPEnterpriseSearchServiceApplicationProxy -SearchApplication $searchServiceApp - (KB).

    If the search service exists, check the available disk space on the query server (corresponding TechNet article).

    You can also verify that the index service is running via Computer Management\Services, it is named Indexing Service.

    Author Comment

    1) I open Powershell and entered the line:        Get-SPEnterpriseSearchServiceApplication
    I get error that it is not recognized.

    2) Went to services and INDEXING SERVICE is not on list. Nothing starts with INDEX on the list
    LVL 14

    Expert Comment

    by:Brad Groux
    So as I stated, if it isn't there you need to create it.
    New-SPEnterpriseSearchServiceApplicationProxy -SearchApplication $searchServiceApp

    Open in new window
    LVL 8

    Expert Comment

    by:Jayaraja Jayaraman
    @author... do you mean, the cmdlet is not recognized from powershell ??if so please execute this line.
    add-pssnapin "microsoft.sharepoint.powershell" and then run Get-SPEnterpriseSearchServiceApplication

    Author Comment

    Powershell already installed.

    I have attempted to run:


    from both SharePoint Management Shell AND Windows Powershell and I still get same error.
    The term 'Get-SPEnterpriseSearchServiceApplication' is not a recognized name of a cdmlet, function, or operable program.

    NOTE:  The search used to work great. It worked for months and months until the day I changed our Domain Administrator password.

    Accepted Solution


    These steps will guide you in case you recently changed a password in Active Directory of an account that is used by SharePoint 2010 and you notice that your services are not working anymore.

    For example, my search service stopped working:

    “The search request was unable to connect to the Search Service.”
    1.Log in to the SharePoint 2010 Central Administration
    2.Under “System Settings” go to “Manage services on server”.
    Here you will find services that have stopped, because the password is wrong.
    3.If you try to start a service it is possible that you will receive a message that it doesn’t work,   because the passwords are different.

    It is easy to fix this. Start the SharePoint 2010 Management Shell. Type in this command:
    Set-SPManagedAccount -UseExistingPassword

    It will ask for your identity (= username) and it will ask for the password of that account.

    Author Closing Comment

    I found the answer searching Google.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    I have just recently built a new SharePoint 2007 farm on a complete Windows 2008 R2 server platform and part of my standard build procedure is to implement a warm up routine, usually in the form of a script that is scheduled every morning to launch …
    Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    This video discusses moving either the default database or any database to a new volume.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now