Raspbmc: "video mode not supported" on tv

Please see this toppic: http://www.experts-exchange.com/Software/MultiMedia_Applications/Q_28150555.html

My problem reappeared after an update of raspbmc. I tried to install openelec and used the same deafult settings which always worked (lately I was using raspbmc, before openelec, I'd prefer raspbmc):

hdmi_safe=0
avoid_edid_fuzzy_match=1
hdmi_mode=85

... but they don't work anymore.

Result: "video mode not supported" on my tv screen. I have no possibility to attach any other screen in order to see what's on the screen.
This is my config: https://www.dropbox.com/s/2ay8vgnlef9zdow/Overview.pdf

Please advise howto configure raspbmc or openelec (probably a setting in config.txt but don't find which one).

J.
janhoedtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerwin Jansen, EE MVETopic Advisor Commented:
These settings should be in /flash/config.txt

Can you ssh to your Rasberry and edit config.txt?

Try setting these:

hdmi_force_hotplug=1
hdmi_drive=2
0
janhoedtAuthor Commented:
I edit the config.txt on the ds card directly.
I ll try the settings.
0
janhoedtAuthor Commented:
So this is my config now, I'll give it a try (note: I was always hearing some bleeps after full boot and I can ping the device but no output on screen, so it is asking for input probably but I cannot see what).

This is the config currently:

arm_freq=850
core_freq=375
force_turbo=1
gpu_mem_512=128
gpu_mem_256=112
disable_overscan=1
start_file=start_x.elf
fixup_file=fixup_x.dat
hdmi_ignore_cec_init=1
hdmi_mode=85
hdmi_group=2
hdmi_force_hotplug=1
hdmi_drive=2
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

janhoedtAuthor Commented:
There is output now but now but screen is scrambled, please advise.
screenshot tv
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Hello Jan, if that's your TV showing the output, I'd disconnect it immediately. I don't recognize beeps during boot of a Raspberry, never heard any. Do you have a computer display with HDMI that you can test with? Other things I can think of is to disable the turbo settings you have, maybe start with a default config.txt (if you haven't tried that already). If you still have a distorted image with default config then I'm suspecting a hardware fault.
0
janhoedtAuthor Commented:
>Do you have a computer display with HDMI that you can test with
Please see my original post: " I have no possibility to attach any other screen in order to see what's on the screen."

>maybe start with a default config.txt
... Duh ... if that would work, why would I have posted this question?

 >If you still have a distorted image with default config then I'm suspecting a hardware fault.
Please see my previous answer + during install of raspbmc, I can see every step of ("install takes a while, grab a coffee")
So, no, no hardware fault.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
>> I have no possibility to attach any other screen
Yup, missed that ;)

About the default config.txt - you did not mention that you've tried that, so don't make " .. if that would work .." remarks. We cannot guess what you've tried sofar, you have to tell us.

Do you have a spare SD card lying around that you can use to install a default raspbmc or openelec on?

About your settings:
hdmi_mode=85 -  720p 60 Hz

Did you try:
hdmi_mode=82 - 1080p 60 Hz  

Btw: I don't have any of the hdmi settings in my config.txt - that's why I'm suggesting a default config.txt (or a separate SD to try).
0
MereteCommented:
Stick with raspbmc
OpenELEC Is a Streamlined, Barebones Version of XBMC
I use an SD not a NAS.Synology.
Do you have the Ras Pi B model?

Side idea since you have now installed openelec, do you have the mpeg plugin?
purchase a VC1 and MPEG2 decoding license.
http://www.raspberrypi.org/tag/mpeg-2/
Raspberry Pi License Install
http://htpcbuild.com/hardware/standalone-htpc-build/raspberry-pi-htpc/raspberry-pi-codec-license-install/
How to
http://www.howtogeek.com/137654/how-to-add-mpeg-2-and-vc-1-video-codec-support-to-your-raspberry-pi/

Raspberry Pi XBMC Solutions Compared: Raspbmc vs OpenELEC vs XBian
http://lifehacker.com/raspberry-pi-xbmc-solutions-compared-raspbmc-vs-openel-1394239600
0
janhoedtAuthor Commented:
Thanks for all your efforts.

This solved it for me:
http://forum.stmlabs.com/archive/index.php?thread-1699.html

I only had to add these two lines to default config and it worked. All the other configs were not needed/killing the correct config.

So this is my (working) config. Also disabled the turbo but not sure if it is needed.

arm_freq=850
core_freq=375
force_turbo=0
gpu_mem_512=128
gpu_mem_256=112
disable_overscan=1
start_file=start_x.elf
fixup_file=fixup_x.dat
hdmi_ignore_cec_init=1
hdmi_mode=85
hdmi_group=2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
Good to hear that it is working again, but how I don't understand. The only difference between your previous config and the one you have now is the turbo setting (and the 2 test settings I suggested). But anyway: have fun!
0
janhoedtAuthor Commented:
> The only difference between your previous >config and the one you have now is the >turbo setting (and the 2 test settings I >suggested).
Not correct.

You suggested to add
hdmi_force_hotplug=1
hdmi_drive=2

What has to be added (as only things)
hdmi_mode=85
hdmi_group=2
0
janhoedtAuthor Commented:
I might not have copy pasted the config correctly ...
hdmi_mode=85
hdmi_group=2
Just as url I posted are only two things to change in default config.
0
janhoedtAuthor Commented:
Found a solution on a forum that did the trick for me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MultiMedia Applications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.