Windows 7 Jumbo Frames > Only working one direction?

Two computers (192.168.0.2 w/MTU 7K and 192.168.0.4 w/MTU 9K) are setup for jumbo frames.  The first (192.168.0.2 ) can ping itself and the other with jumbo frames.  The second (192.168.0.4) can ping itself with jumbo frames but fails when pinging the other.

What's my problem?

Attached is output from second box, (192.168.0.4).

ScreenShot028.png
Geoff MillikanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

giltjrCommented:
I would double check to verify you have jumbo frames enabled and set correctly.  You can ping your address with frames larger than 1500 bytes even with jumbo frames not enabled.

Issue the command:

netsh interface ipv4 show interfaces

to see what the MTU is set to.
0
Geoff MillikanAuthor Commented:
Here's the details on the second box:
C:\Users\johndoe>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.0.4
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

Tunnel adapter isatap.{8C68870B-A7F2-433A-88B4-3B1E175F48DD}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:204d:34f4:3f57:fffb
   Link-local IPv6 Address . . . . . : fe80::204d:34f4:3f57:fffb%13
   Default Gateway . . . . . . . . . : ::

C:\Users\johndoe>
C:\Users\johndoe>
C:\Users\johndoe>
C:\Users\johndoe>netsh interface ipv4 show interfaces

Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
  1          50  4294967295  connected     Loopback Pseudo-Interface 1
 11          10        1452  connected     Local Area Connection


C:\Users\johndoe>

Open in new window


Remember I can successfully ping the second box (192.168.0.4) with Jumbo Frames from the first box (192.168.0.2) per below:
C:\Windows\system32>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 192.168.0.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:1408:2a:3f57:fffd
   Link-local IPv6 Address . . . . . : fe80::1408:2a:3f57:fffd%11
   Default Gateway . . . . . . . . . : ::

Tunnel adapter isatap.{593FD5C6-7B21-4621-AA8A-40106436590A}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

C:\Windows\system32>ping -f -l 5000 192.168.0.4

Pinging 192.168.0.4 with 5000 bytes of data:
Reply from 192.168.0.4: bytes=5000 time<1ms TTL=128
Reply from 192.168.0.4: bytes=5000 time<1ms TTL=128
Reply from 192.168.0.4: bytes=5000 time<1ms TTL=128
Reply from 192.168.0.4: bytes=5000 time<1ms TTL=128

Ping statistics for 192.168.0.4:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Windows\system32>

Open in new window

0
giltjrCommented:
If you notice the MTU size is only 1452, which means that if you have jumbo frames enable you have not set the MTU to 5000.

Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
  1          50  4294967295  connected     Loopback Pseudo-Interface 1
 11          10        1452  connected     Local Area Connection

You may want to issue the netsh command on the other box also.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Geoff MillikanAuthor Commented:
That fixed it!  I didn't know the MTU on the operating system had to be set - I thought changing the MTU on the hardware would cause the OS to change too.  Thanks so much!!

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-do-i-change-the-mtu-setting-in-windows-7/ec01f5d0-7082-4a9d-97b5-1d1dccb121d2
0
giltjrCommented:
Glad to have helped.

Setting it on the hardware allows inbound frames to be larger, but outbound frames are controlled by the OS.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.