• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 281
  • Last Modified:

Download and copying back VM - Using VMClient - Files turned to -flat?

I'm in the midst of downloading a couple VM's purely by using the "Download" Command while browsing the DataStore of the VM.  I simply opened up each VM in the Datastore, selected all files, and chose to Download them to a Windows Share.  I needed to do this to increase the space of the primary data store.  I planned to set up the new DataStore then copying these VM Files right back over.
I noticed that the .vmdk's have now duplicated with one being a small 1k file and the other being the size of the disk but it attached -flat to the end.  So I have Disk.vmdk and Disk-flat.vmdk.  

Am I going to be able to simply add these VM's back to inventory and power them back up?  What about this -flat file?

I'm looking for some advice, and hopefully by morning as that is when I plan to power these back on!  

Thanks all
0
mfehrmann
Asked:
mfehrmann
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
This is completely normal that there are two files for a virtual disk. (you just do not see them through the vSphere Client - they are masked!)

if you were to login at the console, or remotely you would see two files per virtual disk.

the first file

Disk.vmdk - this is the descriptor file which has the disk geometry and information, e.g. scsi or ide etc (it's a text file)
Disk-flat.vmdk - this contains the actual virtual machine data.

When you copy them back they will be fine, but do make sure you copy them both back, as both are needed.
0
 
mfehrmannAuthor Commented:
Thank you. Worked like a charm!  

Copying the files off was a LOT faster than moving the files back though!  Wow!
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now