Can't get Wireless Zero Configuration working

Hi Experts,

I've been given a Dell Latitude D420 (WinXP Pro SP3) laptop, and it had Intel PROSet/Wireless software installed.  It worked, but I had difficulty connecting to some networks (probaly I just wasn't used to it).  So, I uninstalled that Intel software (via Control Panel > Add or Remove Programs > ...).

I then tried to turn on Wireless Zero Configuration, (Run > Services.msc, etc), and WZC now has Status "Started" and Startup Type "Automatic", but even after a reboot, no wireless icon appears in the Sys Tray, so now I can't get any wireless connection.  (I can still get a wired connection though.)  No joy with Googling yet.

Any ideas how I can get this WZC to work?

Thanks.
tel2
LVL 12
tel2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
XP is long gone, so I am going from memory here.

Log in as an administrator and open a command prompt. Run TCP/IP reset.

Delete all wireless profiles.
Then  netsh int ip reset c:\resetlog.txt
Restart the computer

Now remake a wireless profile and see if it works.
0
tel2Author Commented:
Hi John,

I'm using the "admin" user which has administrator priviledges.  Is that OK?

No problem getting the the cmd prompt.
How do I run TCP/IP reset?
How do I delete add wireless profiles?  From the cmd prompt or what?  How?
So then I just run this: netsh int ip reset c:\resetlog.txt.  That should be fine.
How do I remake a wireless profile?  From the cmd prompt or what?  How?

Sorry - I don't know networking.
Thanks.
0
JohnBusiness Consultant (Owner)Commented:
To run TCP/IP reset, run the command I showed above.

Then  netsh int ip reset c:\resetlog.txt

To remove wireless profiles, look at the instructions on the page below. These are similar to what I used to use.

http://www.tp-link.us/article/?faqid=186

I hope that helps.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

tel2Author Commented:
Hi again John,

> To run TCP/IP reset, run the command I showed above.
The only command I saw above was the "netsh..." command.  "TCP/IP reset" doesn't seem to be a valid command.  Please quote the command you are referring to.

> Then  netsh int ip reset c:\resetlog.txt
Will do.

> To remove wireless profiles, look at the instructions on the page below. These are similar to what I used to use.
http://www.tp-link.us/article/?faqid=186

I don't see any wireless profiles currently.  Only Dial-ip, 1394, LAN, Bluetooth, (and New Connection Wizard).  It was there before I removed the Intel thing, but not now.  If the wireless one will appear after the netsh command, then that's fine.

Thanks
0
JohnBusiness Consultant (Owner)Commented:
Check in Device Manager (My Computer, Right Click, Manage, Device Manager) and make sure the Wireless card is installed and working. Look in the networking section.

Also see if there is a switch on the case of the computer that turns off wireless. Make sure it is on.

If you know how to get the wireless driver for the computer, you can do that and reinstall it. That will force the network connections to show up.
0
tel2Author Commented:
> Check in Device Manager (My Computer, Right Click, Manage, Device Manager) and make sure the Wireless card is installed and working. Look in the networking section.
OK - see sceen shot attached.  Is the "57xx" item or the yellow "?" item?  What now?

> Also see if there is a switch on the case of the computer that turns off wireless. Make sure it is on.
There is a switch.  It's got "0" (off), "1" (on) and a spring loaded ">>" area (presumably to start it?).  It was in the "1" area, but I have now pushed it into the ">>" area, and it sprang back to "1".  No apparent change.

> If you know how to get the wireless driver for the computer, you can do that and reinstall it. That will force the network connections to show up.
Maybe later.
DevMan1.png
0
JohnBusiness Consultant (Owner)Commented:
The wireless card is not installed. So either it has a hardware problem (and so the beginning of your issues with this machine).  Otherwise, find the wireless driver (manufacturer's web site) and install it.

You might also consider a third party USB wireless network card for the computer.
0
tel2Author Commented:
As per my original post, the wireless was working before I uninstalled the Intel PROSet/Wireless software a few hours ago.  I've made no hardware changes.  So, I guess I just need the driver, right?
0
JohnBusiness Consultant (Owner)Commented:
Normally uninstalling PROSet will not disable the hardware.

Try to find the proper driver, install it and allow it to install PROset from Intel.
0
tel2Author Commented:
Can I avoid this PROset software and just use WZC?

Also, the Device Manager item we're looking at is the "? Network Controller" with the yellow "?", right?
0
JohnBusiness Consultant (Owner)Commented:
Once you have the driver installed which may install PROset, you can ignore it. Then you should be able to use the Windows setup (which is the link away back).

Yes, the Yellow Icon is the non functional wireless card.
0
rindiCommented:
You probably uninstalled the driver along with the intel utility. Install the utility again, and you should be able to just disable it or choose between which tool you want to use (intel or WZC).
0
tel2Author Commented:
Hi rindi,

> You probably uninstalled the driver along with the intel utility.
True.  I only selected 1 item to uninstall, but it probably took the driver with it.

I've downloaded the Intel PROSET/Wireless software again, installed it.

Any ideas how to disable it so I can choose WZC...anyone?
0
rindiCommented:
It's a long time I've used an intel wireless NIC, but I remember there was an option within the utility where you could choose whether you wanted to use the intel tool or the OS tool. But I don't remember what exactly the words were and how you got to it. Just look through the intel utility...

If you can't find that option there, or if the new versions don't include it anymore, you can just disable the service via msconfig.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
Intel changes its software from time to time. If you have it working, just use the Intel Software. It works fine for me (although I haven't used XP for going on a decade.
0
tel2Author Commented:
Months later...

Sorry guys for the long delay in getting back to you.  Been a bit (or even a byte) busy.

I went into Start > Run > msconfig > OK > Services, sorted the table by the Service column, then unticked the 4 services whose names start with "Intel PROSet/Wireless...", as below:
Servicesthen rebooted.

Then I went into Network Connections, opened the Wireless Network Connection, and it looked like this:
Choose a wireless networkSo I followed those instructions ("Change advanced settings", etc), and got to here:
Wireless Network Connection propertiesAs you can see, I ticked the box to "Use Windows to configure my wireless network settings".

Is that what I was meant to do?

I then tried adding my wireless network, but I don't think I needed to.  I think I ended up deleting it and it came back automatically.

The good news is, it's basically working.  Sometimes it would not connect, despite the "good" signal strength.  So I went in and checked the properties for my "SSS" network that I was trying to connect to, and it showed that the Network Authentication was set to "WPA2-PSK", but my router is set to "WPA2".  So I'd change it to "WPA2" and but it seems to change back automatically.
Network AuthenticationAny ideas what's happening here?  Should it matter whether it's WPA2-PSK or WPA2 when connecting to a WPA2 network?
Thanks.
tel2
0
tel2Author Commented:
Any ideas on this, guys, before I close it?
0
JohnBusiness Consultant (Owner)Commented:
So I'd change it to "WPA2" and but it seems to change back automatically.

I do not think WPA2 was out when XP was alive. Try using WPA and stick with that.
0
tel2Author Commented:
If WPA2 wasn't out when XP was alive, John, then how did it get into the "Network Authentication" dropdown list?  The list contains these options:
    Open
    Shared
    WPA
    WPA-PSK
    WPA2
    WPA2-PSK

As I indicated, it seems to be defaulting to WPA2-PSK.
0
JohnBusiness Consultant (Owner)Commented:
Your network card may be WPA2 and then the installation may have picked it up. The machine also may be newer than XP.

I am using WPA2 on Windows 8.1 on a much newer machine.
0
tel2Author Commented:
OK, but why then should I try using WPA?
0
JohnBusiness Consultant (Owner)Commented:
I am incorrect. WPA2 was out. Try removing the wireless card completely from device manage, Remove it from the machine. Start the machine back up without the card. Now shut down and reinstall the card. Make sure you have the driver on hand and point Windows Hardware Install to this new driver.
0
JohnBusiness Consultant (Owner)Commented:
but why then should I try using WPA?  WPA with PSK/TKIP is decently secure. More secure than is XP now. If WPA works and WPA2 does not, then stick with WPA. It is a good as XP.
0
tel2Author Commented:
Sounds like a long shot, John, and I'm not sure I'm up to it technically or time-wise, but any ideas on the answers to my questions at the bottom of my pictorial post above, which were:
 "Any ideas what's happening here?  Should it matter whether it's WPA2-PSK or WPA2 when connecting to a WPA2 network?"

Thanks.
0
rindiCommented:
WPA2 is part of WPA2-PSK. The "PSK" just tells you that you are authenticating using a pre-shared-key. If you don't use a "PSK", then you are probably using a RADIUS server, and then it would be called something like "WAP2-ENT" for Enterprise.
0
tel2Author Commented:
Thanks guys for your time and effort.
I think I'll just leave it as is at this stage, coz it is basically working now.
0
JohnBusiness Consultant (Owner)Commented:
@tel2 - You are very welcome and I was happy to help as much as possible.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.