disable WiFi when Ethernet connected to laptop?

I'd like to configure the WiFi to become disabled when the employee docks their laptop at work and a cabled LAN connection is established.
msretailitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
If the machine has been set up properly, this is always automatic.

If you need to, you can go into the advanced properties of the wired Network adapter and set it to a higher priority.

I use wireless extensively, but if I plug in an Ethernet cable, it always takes priority.
0
☠ MASQ ☠Commented:
Also a BIOS setup option and with some manufacturers they have their own utility installed to do this (I know both Dell and HP offer this through QuickKeys/QuickSet).
0
arnoldCommented:
I believe the wifi actually does not get disabled, Usually, the ethernet connection has a higher preference (lower metric). I believe this is John hurst meant.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

JohnBusiness Consultant (Owner)Commented:
The Wi-Fi will remain on, but it will not connect if Ethernet is active
0
arnoldCommented:
the wifi will connect if a wireless connection known by the laptop is present.  The traffic might not leave through that connection, but both will be active and functional
0
Ganesh Kumar ASr Infrastructure SpecialistCommented:
Step 1
Press “Windows-R” to open a Run dialog box on the Windows 7 computer.

Step 2
Type “ncpa.cpl” in the Run field, and then click “OK” to launch the Network Connections control panel applet.

Step 3
Click the “Advanced” tab in the top navigation menu to open the Advanced menu.

Step 4
Click the “Advanced Settings” option to open the Advanced Settings dialog box.

Step 5
Click the “Wi-Fi” entry, and then click the downward-pointing green arrow to move the wireless connection down in the priority list. Move the “Wi-Fi” entry below the “Ethernet” entry. The Ethernet entry automatically moves to the top to set the wired connection priority higher than the all other connections.

Step 6
Click “OK” and close the dialog box. The wireless connection will now yield to the wired LAN connection.

Note: If you don’t want to manually configure your network connections, you can download and install a VB script from Microsoft Technet that will automatically disable your wireless connection in Windows 7 when Ethernet is active (see Resources)...

If you want utilities : https://www.raymond.cc/blog/auto-disable-wireless-when-lan-connected/
0
JohnBusiness Consultant (Owner)Commented:
Arnold said "the wifi will connect if a wireless connection known by the laptop is present."

If Ethernet is plugged in and the machine is working properly, Wi-Fi will not connect (even in a known environment) so long as Ethernet is working.

@msretailit  - Are you having issues?  Please let us  know.

The switchover between wired and wireless should be completely automatic in Windows 7 and above. My current machine is Windows 8 and I can plug in Ethernet and my wireless will disconnect immediately (but not disabled - that is not a good idea).
0
☠ MASQ ☠Commented:
If you are still looking to disable rather than change priorities the BIOS option on Dell Latitudes for example is "Wireless Radio Control" or "Control WLAN Radio".  

When enabled in BIOS Setup if a wired Ethernet connection is detected the wireless card is disabled, ignoring any hardware switch settings.
0
msretailitAuthor Commented:
Dear All,

I done what John suggested and I have still problem that wireless will not disconnect when Ethernet will connect.
0
JohnBusiness Consultant (Owner)Commented:
Try running System File Checker. Open an admin command prompt and run SFC /SCANNOW. Allow to complete, run again and restart.

Then reinstall the wireless driver and restart again.

Does that help?
0
msretailitAuthor Commented:
Hi,

still i have the same problem
0
JohnBusiness Consultant (Owner)Commented:
Something has damaged your operating system. Assuming this is Windows 7, you may wish to consider a Windows 7 Repair Install. You can do this with the Windows 7 DVD and sometimes with the Recovery Partition. Here is a Seven Forums Tutorial to assist.

http://www.sevenforums.com/tutorials/3413-repair-install.html
0
msretailitAuthor Commented:
my system is windows 7 and it is brand new,i had tried with other two computers also same result.
0
JohnBusiness Consultant (Owner)Commented:
I used Windows 7 and now Windows 8 and profile switches on both systems work perfectly.

You tried 3 computers in total all Windows 7.

One thing we did not discuss is a third party wireless connector on these machines.

Look for a 3rd party wireless tool (like Access Connections on Lenovo; others have their own name) and see if it is taking over wireless connections. If you have such an application, it may be causing what you see until you set it up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.